QuadBRI and UK ISDN2e


#1

I’ve managed to create all the configurations for the internal SIP phones we have, and they can call each other successfully… I’m now about to try and make my first external call through my Junghanns QuadBRI, but I need to make sure that it’s all configured correctly.

It appears to be working, as there are four red LED’s on the back which are illuminated, but I’m unsure whether to use NT, NT mode or TE. I thought that NT would be the correct as ISDN2e does have an NTE box on the wall, but I’ve read something on the forums that suggest that I should use TE… Does anyone know the correct mode to run it in?

One final question… Does anyone know if the zaptel.conf and zapata.conf supplied by Junghanns work for UK ISDN2e?

All suggestions greatly appreciated.

John


#2

If the telco cables are connected, the lights should turn green… If your telco provides the ISDN lines, you probably should use TE mode.

They should work, yes. If the ‘signalling’ to the ISDN is okay, the led’s should turn green. Feel free to post your zapata.conf if it doesn’t work.

cheers


#3

I’ve got the green lights now, after setting the jumpers to TE so that seems to be OK. Can you have a look to see if if my zapata.conf is correct?

[channels]
;
; Default language
;
;language=en
;
; Default context
;
;
switchtype = euroisdn

; p2mp TE mode (for connecting ISDN lines in point-to-multipoint mode)
;signalling = bri_cpe_ptmp
; p2p TE mode (for connecting ISDN lines in point-to-point mode)
signalling = bri_cpe
; p2mp NT mode (for connecting ISDN phones in point-to-multipoint mode)
;signalling = bri_net_ptmp
; p2p NT mode (for connecting an ISDN pbx in point-to-point mode)
;signalling = bri_net

pridialplan = dynamic
prilocaldialplan = local
nationalprefix = 0
internationalprefix = 00
usecallingpres=yes

echocancel = yes

context=isdn-incoming

group = 1
; S/T port 1
channel => 1-2

group = 2
; S/T port 2
channel => 4-5


#4

A zapata.conf depends very much on your own situation. (context you receive your calls in, etc…)

But on first sight this looks okay, so it should work now… you’ve created 2 groups, you can also create just one if you want… sample:

group=0 callgroup=0 channel => 1-2 channel => 4-5

cheers


#5

[quote=“stoffell”]A zapata.conf depends very much on your own situation. (context you receive your calls in, etc…)

But on first sight this looks okay, so it should work now… you’ve created 2 groups, you can also create just one if you want… sample:

group=0 callgroup=0 channel => 1-2 channel => 4-5

cheers[/quote]

Excellent! That’s much better just having one group… it might mean that we can actually make a call :smile:

Also, does the context matter in the zapata.conf? Does it need to be the same as a context in extensions.conf?


#6

[quote=“jeg1972”]Excellent! That’s much better just having one group… it might mean that we can actually make a call :smile:
Also, does the context matter in the zapata.conf? Does it need to be the same as a context in extensions.conf?[/quote]

The context in zapata.conf is the context in which your incoming ZAP calls arrive… So you could have one that is [from-pstn], and that would have to exist in extensions.conf somewhere…

cheers…


#7

[quote=“stoffell”][quote=“jeg1972”]Excellent! That’s much better just having one group… it might mean that we can actually make a call :smile:
Also, does the context matter in the zapata.conf? Does it need to be the same as a context in extensions.conf?[/quote]

The context in zapata.conf is the context in which your incoming ZAP calls arrive… So you could have one that is [from-pstn], and that would have to exist in extensions.conf somewhere…

cheers…[/quote]

Thanks again stoffell… that helps. All i’m trying to do is get any sip phone phone any other sip phone (which it already does) and for any sip phone to phone any external phone number (which is causing me problems.) Do you think you could over look my conf files and see if I’m anywhere near please?


zptel.conf

loadzone=uk
defaultzone=uk

qozap span definitions

most of the values should be bogus because we are not really zaptel

span=1,1,3,ccs,ami
span=2,0,3,ccs,ami
span=3,0,3,ccs,ami
span=4,0,3,ccs,ami

bchan=1,2
dchan=3
bchan=4,5
dchan=6


My zapata.conf is:

[channels]
switchtype = euroisdn

signalling = bri_cpe_ptmp

pridialplan = dynamic
prilocaldialplan = local
nationalprefix = 0
internationalprefix = 00
usecallingpres=yes

echocancel = yes
echocancelwhenbridged = yes
echotraining = 100

context=isdn-incoming
group = 1

; S/T port 1-4
channel => 1-2
channel => 4-5


My sip.conf is:

[general]
context=isdn-incoming ; Default context for incoming calls
recordhistory=yes ; Record SIP history by default
bindaddr=0.0.0.0 ; IP address to bind to (0.0.0.0 binds to all)
srvlookup=yes ; Enable DNS SRV lookups on outbound calls

localnet=10.0.75.0/255.255.255.0; All RFC 1918 addresses are local networks

[310]
type=friend
context=default
secret=test2
language=uk
host=dynamic
dtmfmode=info
callerid=John <310>
username=310
mailbox=310
restrictcid=no

[311]
type=friend
context=default
username=311
secret=test1
language=uk
host=dynamic
dtmfmode=info
callerid=Ross <311>
mailbox=311
rsetrictcid=no


And my extensions.conf is:

[general]
static=yes
writeprotect=no
autofallthrough=yes

[default]
include => sip-phones

exten => 310,1,Dial(SIP/310|15)
exten => 310,2,Voicemail(u317)
exten => 310,102,Voicemail(b317)

exten => 311,1,Dial(SIP/311|15)
exten => 311,2,Voicemail(u311)
exten => 311,102,Voicemail(b311)

[isdn-incoming]
exten => _X.,1,Dial(SIP/phone${EXTEN},60)
exten => _X.,2,Hangup

[sip-phones]
exten => _9.,1,Dial(ZAP/g1/${EXTEN},60)
exten => _9.,2,Hangup

Does this look like it should phone an external number if I dial ‘9’ first?

Thanks in advance.

John