I need a little help making my first call


#1

I’ve quite happily managed to get all of our SIP devices phoning each other, and leaving voicemail, but I’m a bit stumped when it comes to phoning externally… my set up is UK ISDN2e, a QuadBRI card, Bristuff .2.0-RC8q (hence Asterisk 1.0.10)

All i’m trying to do is get my sip phones to phone any external number. My zaptel.conf is:

loadzone=uk
defaultzone=uk

qozap span definitions

most of the values should be bogus because we are not really zaptel

span=1,1,3,ccs,ami
span=2,0,3,ccs,ami
span=3,0,3,ccs,ami
span=4,0,3,ccs,ami

bchan=1,2
dchan=3
bchan=4,5
dchan=6

My zapata.conf is:

[channels]
;
; Default language
;
;language=en
;
; Default context
;
;
switchtype = euroisdn

; p2mp TE mode (for connecting ISDN lines in point-to-multipoint mode)
signalling = bri_cpe_ptmp
; p2p TE mode (for connecting ISDN lines in point-to-point mode)
;signalling = bri_cpe
; p2mp NT mode (for connecting ISDN phones in point-to-multipoint mode)
;signalling = bri_net_ptmp
; p2p NT mode (for connecting an ISDN pbx in point-to-point mode)
;signalling = bri_net

pridialplan = dynamic
prilocaldialplan = local
nationalprefix = 0
internationalprefix = 00
usecallingpres=yes

echocancel = yes
echocancelwhenbridged = yes
echotraining = 100

context=isdn-incoming
group = 1

; S/T port 1-4
channel => 1-2
channel => 4-5

My sip.conf is:

[general]
context=isdn-incoming ; Default context for incoming calls
recordhistory=yes ; Record SIP history by default
; (see sip history / sip no history)
;realm=mydomain.tld ; Realm for digest authentication
; defaults to “asterisk”
; Realms MUST be globally unique according to RFC 3261
; Set this to your host name or domain name
port=5060 ; UDP Port to bind to (SIP standard port is 5060)
bindaddr=0.0.0.0 ; IP address to bind to (0.0.0.0 binds to all)
srvlookup=yes ; Enable DNS SRV lookups on outbound calls

localnet=10.0.75.0/255.255.255.0; All RFC 1918 addresses are local networks

[310]
type=friend
context=default
secret=test2
language=uk
host=dynamic
dtmfmode=info
callerid=John <310>
username=310
mailbox=310
restrictcid=no

[311]
type=friend
context=default
username=311
secret=rootbeer
language=uk
host=dynamic
dtmfmode=info
callerid=Ross <311>
mailbox=311
rsetrictcid=no

And my extensions.conf is:

[general]
static=yes
writeprotect=no
autofallthrough=yes

[default]
; ### Default Context ###
include => sip-phones

exten => 310,1,Dial(SIP/310|15)
exten => 310,2,Voicemail(u317)
exten => 310,102,Voicemail(b317)

exten => 311,1,Dial(SIP/311|15)
exten => 311,2,Voicemail(u311)
exten => 311,102,Voicemail(b311)

[isdn-incoming]
exten => _X.,1,Dial(SIP/phone${EXTEN},60)
exten => _X.,2,Hangup

[sip-phones]
exten => _9.,1,Dial(ZAP/g1/${EXTEN},60)
exten => _9.,2,Hangup

can anyone cast their eyes over these and give me a little help please?

Thanks in advance.

John


#2

We would need to see your extensions.conf


#3

Hello,

Could you tell what is happening with the incoming calls? You can call from an external phone, through BRI?

From extensions.conf, i can see that you use 9 to dial external numbers. But, don’t you have to strip the prefis (9 in this case), when you dial out? In this case, line: exten => _9.,1,Dial(ZAP/g1/${EXTEN},60) would be: exten => _9.,1,Dial(ZAP/g1/{EXTEN:1},60).

It would be helpfull if you describe what is happening when you try to call out. You can even post here the messages from CLI.


#4

[quote=“mirceahuh”]Hello,

Could you tell what is happening with the incoming calls? You can call from an external phone, through BRI?

From extensions.conf, i can see that you use 9 to dial external numbers. But, don’t you have to strip the prefis (9 in this case), when you dial out? In this case, line: exten => _9.,1,Dial(ZAP/g1/${EXTEN},60) would be: exten => _9.,1,Dial(ZAP/g1/{EXTEN:1},60).

It would be helpfull if you describe what is happening when you try to call out. You can even post here the messages from CLI.[/quote]

I have amended exten => _9.,1,Dial(ZAP/g1/${EXTEN},60) to exten => _9.,1,Dial(ZAP/g1/${EXTEN:1},60), this was a typo, but I still get nothing going out… Incoming calls are now working, although the quality on the calling end is appalling, it is scratchy and the voices are clipped.

When a call comes in, this appears on the console (I have currently hard coded it to come to SIP phone 310:

-- Accepting voice call from '' to 'xxxxxx' on channel 0/1, span 1
-- Executing Dial("Zap/1-1", "SIP/310|60") in new stack
-- Called 310
-- SIP/310-c781 is ringing
-- SIP/310-c781 is ringing
-- SIP/310-c781 is ringing
-- SIP/310-c781 is ringing
-- SIP/310-c781 answered Zap/1-1

== Spawn extension (isdn-incoming, xxxxxx, 1) exited non-zero on ‘Zap/1-1’
– Hungup ‘Zap/1-1’

As far as external calls go, I get nothing appearing on the console or in the messages or event-log… I’ll try it again in a more verbose mode.

John


#5

There is still nothing going out


#6

For those of you who found this while searching for this topic, the resolution was sue to me accidentally switching on ENUM on the phones when setting them up. Switching it off allowed external calls to be made.