Pure-ftp and monitoring calls files

Hi. I install pure-ftp and monitor calls to some directory. But when i connected via ftpclient i can only read moninor files (.WAV), can not delete. But i want to be full access. I think it is because monitor files to be created by asterisk user, but i connect via other ftp user. That is why i can read but do not delete.

I know one solution. Give permission 777 to this folder and files (recursive). In this situation i must give permission after each created file. That is why it’s bad solution.

Other method, i would like connect via asterisk user, but i could not.
I want to be full access.

You should read pureftpd docs. This is not an asterisk problem.

i know it’s no problem asterisk. It’s situation for me. I want to find solution

Quick Linux permissions refresher.

In order to delete, or create, files, you need eXecute and Write permissions on the directory. You do NOT need Write or eXecute on the file itself to delete it.

If you are not creating new directories for the audio files, you can set the permissions once and not have to worry about it in the future.

If you are creating new directories for the audio files, you have some options…

  1. Change the user that you are FTPing into the system as
  2. You may be able to set the UMASK before starting Asterisk. This MAY change the permissions of the files and directories it creates. It may also reset it within the code, I have never tried this solution.
  3. You could call a script with the System() or SHELL() dialplan commands to reset permissions after the file is closed
  4. You could check out the MixMonitor() dialplan command and perhaps use the ‘command’ option.

I also tried this:
I created ftpuser with uid (root) and gid (root). My files owner is root. But ftpuser still do not delete these.