PSTN no audio in with Echo test

I am new to Asterisk and simply trying to get the Echo function to work with a PSTN trunk. When I dial in, I can hear the echo test announcement, however nothing is echoed back to me. Pressing # does also has no effect.

I have tried a second FXO module on my TDM410.

My config files are:

;;; line="4 WCTDM/0/3 FXSKS (EC: VPMADT032 - INACTIVE)"
channel => 4


include /etc/asterisk/dahdi-channels.conf

rxgain = 9.0

hidecallerid = no
callwaiting = no
threewaycalling = yes
transfer = yes
echocancel = yes
echotraining = yes
context = from-pstn
channel => 4

exten => s,1,Playback(demo-echotest) ; Let them know what’s going on
exten => s,2,Echo ; Do the echo test

Note, there is a hash symbol before the include above. This forum is interpreting it as a font control code and so I have deleted it.

It appears that answeronpolarityswitch=yes/no in chan_dahdi.conf, may help, ref

From further reading, it appears that Asterisk must be absolutely clear that it has answered a call before audio paths are established?

I will try this when I get a moment…

In the default PSTN environment (answeronpolarityswitch=no) Asterisk is never sure the call is answered, and has to assume it is answered immediately.

Well, this was not the issue. I have very clear outgoing PSTN audio, and zero incoming audio it seems.

I have also just tried dahdi_monitor:

dahdi_monitor 4 -v

Visual Audio Levels.

Use chan_dahdi.conf file to adjust the gains if needed.
( # = Audio Level * = Max Audio Hit )
<----------------(RX)----------------> <----------------(TX)-------------…#########################*

So, I have continuous high level outgoing audio, even when I can hear nothing from my cell phone, and no incoming audio at all, even when I speak etc.

However, when the Echotest greeting wav is playing, I can see an echo, with the RX levels at about 1/3 of the TX levels…