Problems to connect a SIP telephone to Asterisk

Hey,
I have a Little problem to connect a SIP-Telephone (OpenStage 60) with the Asterisk-Server.
The telephone says that it’s unable to connect to the Server (RF2). I think something is wrong with the authentification.

Asterisk-Server: 172.16.0.6/16
Telephone: 172.16.1.1/16
There is no router and no DNS in the Network. It’s just for the test with Asterisk.

my sip.conf looks like this:

[code][general]
port = 5060
bindaddr = 172.16.0.6
subscribecontext = default
context = default
allowguest = no

[6000]
type = friend
username = 6000
secret = test
host = dynamic
context = demo
[/code]

extensions.conf:

[demo] exten => 6000,1,Dial(SIP,6000) exten => 2600,1,Dial(IAX2/guest@pbx.digium.com/s@default) same => n,Hangup()
(What is the second “exten” for?)

Manager.conf:

[code][general]
enabled = yes
webenabled = yes

port = 5060
bindaddr = 172.16.0.6

[admin]
secret = *****
read = system,call,log,verbose,command,agent,user,config
write = system,call,log,verbose,command,agent,user,config,originate

[6000]
secret = test
read = system,call,log,verbose,command,agent,user,config
write = system,call,log,verbose,command,agent,user,config,originate
[/code]
(admin secret censored)

Telephone configuration:
IPv4, no DHCP
IP: 172.16.1.1/16
Port SIP Server, registar, Gateway, local: 5060
Terminal Number: 6000
Display identity: 6000
enable ID: checked
SIP Server address: 172.16.0.6
SIP registar address: 172.16.0.6
SIP Gateway address: -
Server type: other
User ID: 6000
Password: test

Unfortunately I couldn’t upload any pictures of the telephone config.
So maybe you can help me with the configuration. Did you see any wrong entrys?
I would be happy if someone could help me.

Best regards,
veitv

First of all: If You just want to connect a SIP-Phone to Asterisk there’s no need to configure a manager-Account in manager.conf - but, that’s not the primary error.

Your connection fails at least because You configured Your Asterisk-Manager-Interface to run on port 5060 which is the same as the sip-port 5060. I would expect, that probably the manager-Application is loaded earlier by Asterisk, thus SIP-connections won’t be available as port 5060 is already blocked.
Normaly there should be no need to change the managers standard-port (5038) to any other value.

Anyhow: Never ever let two services try to listen to the same port at the same machine. This will never ever work, at least one of the services will definitely fail.

And: You probably should read a bit about the concepts of Asterisk (in this case especially sip.conf, extensions.conf, protocols and something about the Dial-Synatx) before trying to start. Questions like Your [quote](What is the second “exten” for?)[/quote] are really simple to determine by some self-studies …

[quote=“abw1oim”]

Your connection fails at least because You configured Your Asterisk-Manager-Interface to run on port 5060 which is the same as the sip-port 5060. I would expect, that probably the manager-Application is loaded earlier by Asterisk, thus SIP-connections won’t be available as port 5060 is already blocked.[/quote]

Asterisk listens on SIP (5060) using UDP, AMI uses TCP so it doesn’t matter if the use the same port number because each service use a different protocols

You might run this command netstat -apn |grep -i 5060 and check if both port are listening

I made a test on my server changing the standard sip port to 5038 the same for AMI and still working fine.

root@asterisk-dominicana:~# netstat -apn |grep -i 5038
tcp 0 0 0.0.0.0:5038 0.0.0.0:* LISTEN 18348/asterisk
tcp 0 0 127.0.0.1:5038 127.0.0.1:42790 TIME_WAIT -
tcp 0 0 127.0.0.1:41383 127.0.0.1:5038 ESTABLISHED 26549/python
tcp 0 0 127.0.0.1:5038 127.0.0.1:42809 TIME_WAIT -
tcp 0 0 127.0.0.1:5038 127.0.0.1:41383 ESTABLISHED 18348/asterisk
tcp 0 1 61.11.118.232:59078 192.12.222.179:5038 SYN_SENT 26549/python
tcp 0 0 61.11.118.232:36325 65.181.121.120:5038 ESTABLISHED 26549/python
tcp 0 0 127.0.0.1:5038 127.0.0.1:42810 TIME_WAIT -
udp 0 0 0.0.0.0:5038 0.0.0.0:* 18348/asterisk

This is only true when running SIP signalling exclusive with transport=udp (what’s the standard of course).

The above statement is true only if the option tcpenable=yes, default is no as abw1oim wrote.

So I think his issue it is another thing check iptables and use netstat as I mentioned before.

Thank you for your response.
I changed the port in the manager.conf back to 5038.

netstat -apn | grep -i 5038 tcp 0 0 172.16.0.6:5038 0.0.0.0:* LISTEN 12526/asterisk

netstat -apn | grep -i 5060 udp 0 0 172.16.0.6:5060 0.0.0.0:* LISTEN 12526/asterisk

I forgot to say that I’ve installed the Asterisk-GUI, too.
I don’t think that it’s a problem with the GUI but just to be sure here is my http.conf:

[general] enabled = yes enablestatic = yes bindport = 8088 prefix = asterisk backups = /var/lib/asterisk/gui_backups moh = /var/lib/asterisk/moh
The loading of the GUI takes a lot of time (“Checking write permissons for gui folder”). Maybe there is something misconfigured?

I tried ‘iptables -t filter -L’ and the source and destination everywhere is set to “anywhere” so I think there isn’t a problem or did I have to look for something special?

Are you aware the the AsteriskGUI hasn’t be supported for several years, unless Synology are supporting it, and there are doubts that they are.

But shouldn’t the telephone be able to connect to the Server even if Asterisk-GUI has a few problems?

edit: The RF2 error says that the teleohone is unable to register to the Server and that it’s a server error (But I think it could be a telephone mistake too… maybe if something is misconfigured) Does anyone know a bit from the OpenStage telephones?

There we have a problem :imp: :imp:
SYNOLOGY says : no support to third party packages nor forum posts follow-up in this area !

Who can help?

Asterisk GUI clearly not working with new Asterisk version 13.
Asterisk GUI not supported by SYNOLOGY.
Asterisk GUI not supported by ASTERISK.

Which GUI can be used to manage ASTERISK configurations from a Windows based PC ?