Problems register local users

Hi!

I’ve downloaded Trixbox and get it up with my VoIP provider. So I can get calls from cellphones into my Asterix/Trixbox box, but my problem is that my clients (IP phones) won’t register on my Asterix box.

I use a softphone called Express Talk. My options:
Account number: 200
Server: 192.168.1.2:5060
Local SIP port: 5071
Local RTP: 8000

This gives me the following:
12:55:18 Restarting the SIP Engine so settings take effect.
12:55:25 SIP Private IP is: 192.168.1.99:5071
12:55:25 SIP Public IP is: ***.***.***.***:5071
12:55:25 SIP Number: 200@***.***.***.***:5071
12:56:06 Server 192.168.1.2:5060 did not respond to register (user 200)
12:56:06 Check server details for that line

In my router I have forwarded the following ports to my Asterix box:
5004 - 5082, 3478, 4569, 2727, 8000-20000 (all UDP and TCP)

My Asterix box has SIP port 5060.
I know my problem is local, does anybody have any ideas?
Thanks…

Hi there. I recommend you use the xlite softphone. Download it at www.xten.com

I think it is the best softphone on the sip standard. It works good with asterisk.

David Medina

[quote=“marra87”]Hi!

I’ve downloaded Trixbox and get it up with my VoIP provider. So I can get calls from cellphones into my Asterix/Trixbox box, but my problem is that my clients (IP phones) won’t register on my Asterix box.

I use a softphone called Express Talk. My options:
Account number: 200
Server: 192.168.1.2:5060
Local SIP port: 5071
Local RTP: 8000

This gives me the following:
12:55:18 Restarting the SIP Engine so settings take effect.
12:55:25 SIP Private IP is: 192.168.1.99:5071
12:55:25 SIP Public IP is: ***.***.***.***:5071
12:55:25 SIP Number: 200@***.***.***.***:5071
12:56:06 Server 192.168.1.2:5060 did not respond to register (user 200)
12:56:06 Check server details for that line

In my router I have forwarded the following ports to my Asterix box:
5004 - 5082, 3478, 4569, 2727, 8000-20000 (all UDP and TCP)

My Asterix box has SIP port 5060.
I know my problem is local, does anybody have any ideas?
Thanks…[/quote]

Yes, x-lite is great. I also recommend changing the sip port 5071 to the default sip port 5060, that might be causing some conflicts too. On x-lite the sip port is 5060 by default anyway. As an experiment, when I changed the SIP port on my x-lite to 5061 it stopped working due to the fact that the * SIP bindport= (in sip.conf general settings) was set to 5060. So until I set the x-lite SIP port back to 5060 as the * bindport= it started working again.