Problem with incoming calls!


#1

hy!

i use this system:
a router (netgear)
behind the router a linux system (mandrake where asterisk is running)
behind the router a hardphone grandstream bt101

i use sipgate.at and voipbuster as register!
the function of outgoing calls is perfekt! (first i had codec problems, but now i have solved them!) i can hear the other one, and the other one can hear me! --> perfekt!

but!!
when i get a incoming call from sipgate.at, then i can´t hear the other one! the other one (who called me) can hear me!?

whats the problem?

hear are my config files:

sip.conf

[general]
port=5060
bindaddr=0.0.0.0
qualify=no
context=default
disallow=all
allow=ulaw
allow=alaw
allow=gsm
allow=g723.1
allow=ilbc
allow=slinear
srvlookup=yes
language=de
externip=MYDOMAIN

register => UID_SIP:PWD_SIP@sipgate.at/UID_SIP

[sipgate]
type=friend
username=UID_SIP
host=sipgate.at
fromuser=UID_SIP
secret=PWD_SIP
fromdomain=sipgate.at
nat=yes
insecure=very
qualify=yes

[voipbuster]
type=peer
username=UID
host=sip.voipbuster.com
fromuser=UID
secret=PWD

[grandstream1]
type=friend
username=grandstream1
secret=PWD
host=dynamic
disallow=all
allow=ulaw
dtmfmode=info
context=default
port=5060

extension.conf

[default]
exten => _9.,1,SetCallerId,9526715
exten => _9.,2,Dial(SIP/${EXTEN:1}@sipgate,30)
exten => _9.,3,Hangup

exten => _8.,1,Dial(Sip/${EXTEN:1}@voipbuster,60)
exten => _8.,2,Hangup
exten => _8.,102,Busy

exten => 600,1,Playback(demo-echotest)
exten => 600,2,Echo
exten => 600,3,Hangup

exten => 9526715,1,Dial(SIP/grandstream1,60)
exten => 9526715,2,Hangup
exten => 9526715,102,Busy

rtp.conf --> i have changed the ports(first i had 10000-20000 with same problem)
--------------------------------;
; RTP Configuration
;
[general]
;
; RTP start and RTP end configure start and end addresses
;
rtpstart=5000
rtpend=5008
;
; Whether to enable or disable UDP checksums on RTP traffic
;
;rtpchecksums=no

i forwarded these ports from the router to the asterisk server(UDP and TCP):
5060
5000-5008
4569
2727

bt101 configuration:
login to asterisk
sip 5060
rtp 5004

WHAT IS THE PROBLEM???
I hope anyone can help me! :smiley:

sorry for my bad english! :wink:

mfg
little


#2

Well it sounds like a NAT/firewall problem - but your setup looks ok. Can you receive incoming calls from Voipbuster?


#3

hy!

with voipbuster it is not possible to receive incoming calls!
should i test an other one?

mfg


#4

Yes you can receive free calls with Voipbuster - peer to peer. Can you get someone to call you peer to peer via Voipbuster?

Alternatively, yes, it may be a good idea to get another account somewhere else to test it with - but it won’t necessarily solve your problem. It will just give you a bit of information about the nature of the problem.

I’ve found Sipgate quite tricky to get working in the past - although i’ve never experienced the problem you describe - so if you can get another service to work properly, at least you’ll know it’s just some Sipgate weirdness you’ve got to find a way to solve.


#5

hy!

now i set up an softphone behind the router and there are no problems with it! but it has the same problem with incoming calls from sipgate! --> for me it looks like a problem with sipgate or a problem with NAT?? or a problem with the firewall (from the router)!

wich other services (sip) can i use for free?

mfg
little


#6

i had problems getting proper registration with sipgate.co.uk using 1.0.9 and fixed it with a few extra lines in sip.conf under [general]:

localnet = 192.168.10.0/255.255.255.0 ; your local subnet details externip = xxx.xxx.xxx.xxx ; your 'external' address

instantly allowed asterisk to be registered with sipgate.co.uk, device shows in their status section, and incoming calls work fine. maybe worth investigating ??


#7

hy!

@baconbuttie
i tried this lines with no changes!!

BUT
I have solved the problem! :wink:

i changed the rtp port on the phone to something else then asterisk is!
then on the firewall i forwarded this port to the phone!
and in the sip.conf i set canreinvite=no for the phone and for sipgate!

–> now incoming and outgoing calls are perfect!!
maybe this hints helps anyone! :wink:

mfg
little