Problem with incoming Calls (Gosub)

I’m trying to configure asterisk (11.13.1~dfsg-2+b1) for inbound & outbound calls.
Outbound call seem’s to working but, in incoming calls, i have some errors in log :
== Using SIP RTP CoS mark 5 -- Executing [33XXXXXXXXX@default:1] Gosub("SIP/12.b2bua.sip.internal-00000027", "33XXXXXXXXX,stdexten(SIP/33XXXXXXXXX&IAX2/33XXXXXXXXX)") in new stack [Jun 5 18:45:07] NOTICE[7148][C-0001133f]: pbx.c:4948 pbx_extension_helper: No such label 'stdexten' in extension '33XXXXXXXXX' in context 'default' [Jun 5 18:45:07] WARNING[7148][C-0001133f]: pbx.c:12355 pbx_parseable_goto: Priority 'stdexten' must be a number > 0, or valid label [Jun 5 18:45:07] ERROR[7148][C-0001133f]: app_stack.c:548 gosub_exec: Gosub address is invalid: '33175431521,stdexten(SIP/33XXXXXXXXX&IAX2/33XXXXXXXXX)' == Spawn extension (default, 33XXXXXXXXX, 1) exited non-zero on 'SIP/12.b2bua.sip.internal-00000027'
Thanks in advance.

Please include the complete extensions.conf, not just the top level file.

Please mark it as unformatted text (</> button) so that it formats properly.

You have no subroutine called stdexten in the part of extensions.conf that you provided.

The configuration is complete. The problem is that i havn’t any subrooutine called stdexten in my extensions.conf. the hole configuration is listed in the topic.

If this is a pattern then you should start with an underscore. Change this and try again, it should be like this


I think the Xs are obfuscation, rather than a pattern.

Thank you for your replay.
I have switched some line like you say, it’s work for 10 calls and after that, i have the same error that i post in the topic. :confused:

Are you using some sort of GUI front end, as it is possible that you have a GUI trying to construct dialplans dynaically, but you have broken it my modifying the files it assumes will set the fixed parts of the dialplan.

I guess so, but i don’t set a GUI frond end or nothing else to construct dialplans if it’s broken. But, if there is a GUI trying to construct dialplans, how can i disable it ?

You’d need to know why it was there in the first place. A source code install of Asterisk will not do this.

I have pushed asterisk to some test, and i have find a file extensions.ael containing the same demo configuration, so if i comment all line in extensions.ael i got many errors that disapear, but i still have the error with gosub and stdexten. So, is there any method to have the same configuration in extensions.ael as extensions.conf ?
thanks in advance.

AEL is an alternative language for the diaplan. If you don’t want to use AEL, comment it all out, or rmove the file entirely. Having both files is usually wrong.

Another think. I have watched the few incoming calls that pass, and i have constat that there is no SIP/12.b2bua.sip.internal in logs :

== Using SIP RTP CoS mark 5
– Executing [33XXXXXXXX@incoming:1] Set(“SIP/keyyoout-00000004”, “idDial=436156”) in new stack
– Executing [33XXXXXXXX@incoming:2] Verbose(“SIP/keyyoout-00000004”, “Call from 33XXXXXXXX1 to 33XXXXXXXX”) in new stack
Call from 33XXXXXXXX1 to 33XXXXXXXX
– Executing [33XXXXXXXX@incoming:3] Macro(“SIP/keyyoout-00000004”, “automon”) in new stack
– Executing [s@macro-automon:1] Set(“SIP/keyyoout-00000004”, “MONITOR_FILENAME=436156”) in new stack
– Executing [s@macro-automon:2] MixMonitor(“SIP/keyyoout-00000004”, “436156.wav,b”) in new stack
== Begin MixMonitor Recording SIP/keyyoout-00000004
– Executing [33XXXXXXXX@incoming:4] Goto(“SIP/keyyoout-00000004”, “work,33XXXXXXXX,1”) in new stack
– Goto (work,33XXXXXXXX,1)
– Executing [33XXXXXXXX@work:1] Answer(“SIP/keyyoout-00000004”, “”) in new stack
> 0x73e5740c3620 – Probation passed - setting RTP source address to XX.XX.XX.XX:38234
– Executing [33XXXXXXXX@work:2] Dial(“SIP/keyyoout-00000004”, “SIP/33XXXXXXXX,40,m(attente2)”) in new stack
== Using SIP RTP CoS mark 5
– Started music on hold, class ‘default’, on SIP/keyyoout-00000004
– SIP/33XXXXXXXX-00000005 is ringing
– SIP/33XXXXXXXX-00000005 is ringing

Is that normal ?