Problem to transfer call with pjsip

Hi *,

(I’m new here on the forum, the mailing list doesn’t seem to have picked up my message).

Maybe I found a small bug or I am doing something wrong.

When I do a “Transfer” on a call that arrives via PJSIP, Asterisk sends a “302 Moved Temporarily” to perform the transfer.

Unlike chan_sip, the contact header is set different and maybe incorrectly with PJSIP:

Contact: Transfer sip:+49xxx@****

Contact: sip:+49170xxx@****

The difference are domain (chan_sip) vs. local IP address (pjsip) and the additional (wrong?) port number. The IP address is the one of my router, but the port number should be 25060, because asterisk is configured to this port.

The transfer works with asterisk 11 and chan_sip. It does not work with
pjsip and asterisk 18.

I have not been able to find any precise references in the RFC. At least the port seems doubtful to me. Does anyone know more?



The RFC will not say anything about what happens if you only provide the user part of the target URI, as what goes over the wire is the full URI. I’d suggest providing the complete new target URI.

Hi david551,

thanks david551, I think, I found my mistake.

This worked for chan_sip: Transfer +49xxx

With pjsip a complete URI was needed. And there I made a mistake.

Thanks for your quick response.

Have a nice weekend


Hi *,

unfortunately it still doesn’t work. I now call
And still the contact-Header in the 302 Response is set to
Contact: sip:+49xxx@
Whats am I doing wrong with the transfer in pjsip?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.