Problem, Manager interface from Activa TSP



I just upgraded (new server and OS to) to Asterisk from 1.4 and also Activa TSP from 1.4 to 1.6 ( When I try to make a call from outlook 2007 via Activa TSP the phone rings and i pick up but then nothing happens. My first thought was of course a dialing plan problem but debugging in CLI shows nothing after the “answer” when I pick up… I looked at the command from Activa with wireshark and the external number is present and Asterisk seams to accept the command but still nothing.

In further tests I tried to set up a call from ext 1701 to ext 1005. First manually with telnet to port 5038:

Action: Originate
Channel: SIP/1701
Context: default
Exten: 1005
Priority: 1
Timeout: 30000
Callerid: 1005

Works fine!

Then via Activa (see log below):

Action: Originate
Channel: Local/1701@default/n
Exten: 1005
Priority: 1
Callerid: 1701 #CallId=35 <1701>
Context: default
Variable: originating=1701
ActionID: 21
Timeout: 30000 Async: 1

Dont work!

I use the same username and secret.
In my opinion this proves that it is not a dialplan issue and not a permission issue for “orginate” but rather something wrong in the command sent from Activa.

Any suggestions, anyone?

Solved! :stuck_out_tongue:

I got help in Activias forum and it seems a bug where introduced in some 1.6.2 releases for example that I used.

I upgraded to and now this works!

I hope this thread can help someone else!