problem ./install_amp --username=asteriskuser@localhost --pa

i am trying to Install FreePBX on XUbuntu 12.04 Server and get this error when trying to connect to the DataBase:

./install_amp --username=asteriskuser@localhost --password=$ASTERISK_DB_PW --webroot /var/www

Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Console_Getopt: option requires an argument --password
can anyone help me please?

thank you for your interest but i couldn’t find the solution there.i am not experienced on asterisk installation.

You were redirected because you were not installing Asterisk. FreePBX is an add on, which provides a GUI, and is supported at the place I gave you.

My question is just to be clear: This var is replaced with the actual value?

If you could set the variable to a the value you want, you can also directly use the value in the shell command.

yes i know because i have already used Freepbx with AsteriskNow but i would like to install it on Ubuntu server now (with Asterisk on it).I followed this site: and when i ran the command ./install_amp --webroot /var/www, i received the issue…

Can you paste the real command used for the install?

I gave the website where it is mentioned but the command is:
./install_amp --username=asteriskuser --password=$ASTERISK_DB_PW --webroot /var/www

I’m still wondering if you replace the $ASTERISK_DB_PW with the real password like:

Ask the people who wrote the command. If someone uses a variable, I expect something to have already set it, and that it might be referenced by other things as well.

[quote=“navaismo”]I’m still wondering if you replace the $ASTERISK_DB_PW with the real password like:

yes i did it but even if i would’nt do it there is a line "export ASTERISK_DB_PW=amp109 " in the tutorial ( which is supposed to do it. isn’t it?
however i tried the two options i.e with the variable and with the value but nothing worked!

Then just use theinstall_amp script without arguments, if i recall the script will ask you for those values during the installation.

Please supply the complete contents of the script. It is NOT part of Asterisk, so we can’t support it without knowing what it contains.

Its the main script for install FreePBX from sources. When I have installed fpbx always use that script without arguments since it will ask for them.

The support URL for FreePBX has already been provided.

Sorry for not replying for so many days, I have been trapped in other things.
thank you navaismo and others but it doesn’t work because even using ./install_amp without arguments it ends with the same error after prompting the username, password, etc…
i even reinstall my server with xubuntu 13 but no solutions! :confused:

hi!there is something new.i think the problem was with mysql server because we purge the database and recreate another user after what we could use ./install_amp with informations of that user.
Thanks to all!