Poor Sound Quality: Cause CODEC translation?

So here is the story:

I had be putting off the upgrade of asterisk, mainly because I was going to have to build it from source. :frowning:
To make a long story short, 20 hours later, I get everything back to normal, well I thought so - until I tried out one of my voice menus :exclamation: It sounded about like I was talking across the world on a old CB radio!

That was on the TDM-400P,
I proceeded to try out my softphone which had the same results.
One clean reinstall later, asterisk was not working any better.
Next I tried Zoiper with IAX, which worked fine!

Finally I found, that if I was using GSM as my codec every thing worked fine on SIP or IAX.

But that still leaves my TDM400 not working:(

If any one has any ideas on how to get asterisk working better, please let me know!


I should add that my audio files are in GSM format and they sound really bad when using u-law.
But when I call using GSM and listen to GSM files it sounds fine…

From this I gather that there must be an issue with some setting somewhere… That I don’t know about!

To solve the problem with the sound files, simply install u-law or linear variants of the same files.

WIthout a better description of the distortion, it is difficult to say whether your problem is simply a shortage of CPU power, or whether it is a bug in the codec, but either way, installing multiple formats will avoid it for the sound files. I hope you are not trying to run this on a virtual machine.

Thanks so much for your help :smiley:

The strangest thing about it all, is I had this 500MHz board running for a year or so without problems…
But now that I do the upgrade to Asterisk 1.6, I get this issue with codecs :frowning:

Oh well at least there is a fix. :smile:

Thanks Again,

I’ve just run into this myself in a roundabout way. After upgrading to 1.6, all my voicemails were sounding like poo. All my phones are using ulaw, but I noticed 1.6 seems to prefer playing the gsm files back and transcoding rather than using the wav’s as it seems to have been doing under 1.4 since I installed the system 2 years ago. I had not changed the voicemail defaults of recording in wav49|gsm|wav.

This seems to be a bug in transcoding gsm->ulaw — ulaw->gsm sounds fine.

Just in case anyone runs across this thread in the future with a similar problem:

This turns out to be caused by a bad optimization when building with GCC 4.2. See https://issues.asterisk.org/view.php?id=11243 for more info; but in short it can be fixed quickly by patching the Makefile of the gsm module to turn down optimization for that module (see bug link) – or by building with GCC 4.1. Some other possibilities too.