Polycom 301 HOLD does not start MOH

Hello, I have a Polycom 301 phone that used to work perfectly. I have updated the bootrom to 3.2.2 and SIP version 2.0.1. Upon testing, I realized that MOH does not kick in when I hit the Hold button (or use the softkey) on the 301. The call is put on hold on the phone (mic. is muted), but it appears as if Asterisk is unaware that the call has been put on hold. (Pressing the Hold button does generate SIP traffic to Asterisk, but the MusiconHold command is never executed)

This used to work fine. It also works fine with an xlite softphone I use.

Any ideas if this is a problem with the phone’s software or an asterisk issue?

make sure MOH works. Have an exten that just runs MusicOnHold(). Dial it. Any music?

Also when you put a call on hold check the console. Does it say ‘starting music on hold for xxxxx’?

If you dont get MOH try grabbing the asterisk-extras package and set the MOH mode to be ‘files’… works better than mpg123 usually.

Yes, MOH works with every other phone I use. Just not the 301’s.

Just for kicks, I installed an identical system locally (same LAN as the 301s), with same OS, updates, and *, and it works.

Connecting to my remote * server does not work.

Is MOH signals part of SIP communication, or RTP traffic? Is it possibly a NAT issue? I have tried EVERYTHING for 3 days, and finally just gave up. If anyone can offer any tips or advice, I would really appreciate it.

Yes, I have tried multiple revisions of the 301’s bootrom and SIP firmware. Funny thing is, I seem to recall MOH used to work on the 301’s but don’t know when they stopped.

Hold is part of SIP… as i recall it involves reinviting the call to or something…

is canreinvite=no set? you can get a good effect by only setting canreinvite=no on the WAN links/carriers and leaving IP phones on the LAN set for canreinvite=yes…