Please help


#1

I’m trying to test the communication of phone1 to my asterisk server and I’m just not having any luck playing back the file tt-monkeys.gsm

so if i press more than 1 number it should playback tt-monkeys

I get a dial tone, press the numbers, I don’t hear tt-monkeys :frowning:

All I have is my asterisk server, sipura 3000 and a phone

my sip.conf is

host = ip address of the sipura 3000

[general]
context=line1
;sipura1 describes the line that connects
;to the phone on our desk - the handset
[sipura1]
type=friend
context=phone1
secret=g00dpazzwerd123
host=192.168.2.4
dtmf=rfc2833

extensions.conf is


[phone1]
exten => _X.,1,Answer
exten => _X.,2,Wait(2)
exten => _X.,3,Playback(tt-monkeys)
exten => _X.,4,Hangup

in the sipura 3000 web configuration i have only modified the line 1 tab
under Proxy and Registration i have
Proxy: 192.168.2.2 (address of asterisk server)
Use Outbound proxy: no
outbound proxy: empty
Use OB Proxy in dialog: yes
register: no
make call without reg: yes
register expires: 3600
ans callwithout reg: yes
use dns srv: no
dns src auto prefix: no
proxy fallback intvl: 3600
proxy redundancy method: normal

Subscriber information
display name: sipura1
user id: sipura1
password: g00dpazzwerd123
use auth id: no

I hope I provided enough info, please help[/code]


#2

If you do a ‘sip show peers’ what does it show? My guess is you will find the Sipura is not registered. On mine I have register set to yes.


#3

ok I did a sip show peers

(192.168.2.4 is the address of the sipura 3000)

name/user: sipura1
host: 192.168.2.4
dyn nat:
acl:
port: 5060
status: Unmonitored

1 sip peers [1 online, 0 offline]

just checked the web configuration of the sipura 3000
under the info tab and under line 1 status

Registration State: Not Registered

I changed Register to yes, and registration failed?

What can cause registration to fail?

(I thought this was supposed to be an easy setup, it appears that way on the Systm episode featuring asterisk revision3.com/systm/asterisk/)


#4

In your sip.conf you did not have ‘username’ set. You need that set. Also I assume that you have the Line 1 line enable.

For myself the Sipura was VERY easy to set-up. For the FXO side you may want to change the number of rings to ‘1’ (which is the smallest value you can set) so you can get the caller ID.

Also if you go to http://sipura.com you can download the full manual for the 3000.


#5

line1 is enabled in the sipura web configuration
line1 status
hook state: on
Last registration at: 0/0/0 00:00:00
Message waiting: No
Call 1 state: idle
Call 1 tone: none
Registration state: failed
Next Registration in: 15s
Call Back Active: No
Call 2 state: Idle
Call 2 tone: None

is registration necessary? in the systm video featuring asterisk i believe he disabled registration but he never goes into detail.

It seems like i’m doing everything write and i’m still failing for some reason. the asterisk server is plugged directly into the same router as the sipura

sip.conf

[general]
context=line1

[sipura1]
type=friend
context=phone1
username=sipura1
secret=g00dpazzwerd123
host=192.168.2.4
dtmfmode=rfc2833

extensions.conf

[phone1]
exten => _X.,1,Answer
exten => _X.,2,Wait(2)
exten => _X.,3,Playback(tt-monkeys)
exten => _X.,4,Hangup

sip show peers produces
name/username: sipura1/sipura1
host: 192.168.2.4
dyn
nat
acl
port: 5060
status: unmonitored

line enabled: yes
proxy registration
proxy: 192.168.2.2
register: yes
register expires: 3600
use dns srv: no
proxy fallback intl: 3600
use outbound proxy: no
use ob proxy in dialog: yes
make call without reg: yes
ans call without reg: yes
dns srv auto prefix; no

subscriber information
display name: sipura1
user id:sipura1
password: g00dpazzwerd123
user auth id: no


#6

Set the host to DYNAMIC in the sip.conf, does that help ?


#7

No luck, is it possible that something is blocking communication? (They are on the same subnet, just my small home network) I’m new to linux but this a Suse 10 box with pretty much everything installed. I haven’t customized it, just installed asterisk thats it.

Are there any other pieces of information I could give that may be helpful?

if this helps


#8

bump


#9

Perhaps you should begin by reading the documentation available for Asterisk. If all you did was install Asterisk, you have an Asterisk server and that’s it.

You should not expect it to do anything at all.

Try to think of it as an email server; If all you did was install the post office software, and didn’t configure it to speak to the rest of the email servers in the world, and didn’t add any email accounts and users, would you expect to be able to use it?

Begin by reading the book called “Asterisk, the future of telephony”. It’s available free if you download it. You’ll find a link to it in a sticky message located in the Docs forum.


#10

I already have that book, I have read the documentation, everything appears to be configured correctly as you can see, I am not getting any errors when asterisk starts, this is why this is frustrating.

When I said I haven’t customized it, I mean suse specifically, I haven’t done anything special besides install asterisk, and asterisk appears to be configured correctly

Can someone tell me the steps to troubleshoot this? (communication between sipura and asterisk)


#11

Try changing your contexts everywhere to [default]. It’s the easiest way to make certain that all of your settings can work with each other.

Re-start Asterisk using a -cvvvvv startup. See if your sip client can login. (sip show peers) If it can, try placing a call. If it can’t, start by making sure it can register with the Asterisk server. Again, this is a lot like setting up an email server. Your sip.conf file is where you setup your “email” accounts. Make certain that your sip client (sipura adapter, softphone, whatever…) can regisiter, or nothing at all will work.

Once it can register, then start working on changes your extensions.conf file.


#12

If you installed everything, you may want to check your firewall by typing the following command at your linux prompt.


#service iptables status

If the status is not “Firewall is stopped.”, you can shut it down unitl next reboot so you can test Asterisk.


#service iptables stop