Please help me to test calls with g723 (passthrough)


#1

Hello,
I have compiled asterisk in centos …and i am using a2billing software also … i converted all .gsm sound files to .g723 with a software and copied to /var/lib/asterisk/sounds .now sounds folder contained .gsm files and .g723 files… its working fine with g711 and gsm codecs…but when i try to make calls with g723 codec its showing the error …i allowed all codecs in sip.conf …I need just g723 passthrough …is there any special configuration for that …please guide me to configure it…

– Executing Answer(“SIP/2111205810-1f31”, “”) in new stack
– Executing Wait(“SIP/2111205810-1f31”, “2”) in new stack
– Executing DeadAGI(“SIP/2111205810-1f31”, “a2billing.php”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/a2billing.php
a2billing.php: IDCONFIG : 1
a2billing.php:
– AGI Script Executing Application: (SetLanguage) Options: (en)
Apr 2 02:17:57 NOTICE[3411]: channel.c:1703 ast_set_write_format: Unable to find a path from gsm to g723
Apr 2 02:17:57 NOTICE[3411]: channel.c:1703 ast_set_write_format: Unable to find a path from gsm to g723
Apr 2 02:17:57 WARNING[3411]: file.c:787 ast_streamfile: Unable to open digits/10 (format g723): No such file or directory
Apr 2 02:17:57 NOTICE[3411]: channel.c:1703 ast_set_write_format: Unable to find a path from gsm to g723
Apr 2 02:17:57 NOTICE[3411]: channel.c:1703 ast_set_write_format: Unable to find a path from gsm to g723
Apr 2 02:17:57 WARNING[3411]: file.c:787 ast_streamfile: Unable to open prepaid-enter-dest (format g723): No such file or directory

Thanks.