PLAY issue (play not completed totally)

Hi

I am using ari-client with nodejs.

During a call, I play multiple of audio files, for examples:
chan.play(‘Hello’)
chan.play(‘Welcome to the office of’)
chan.play(‘Doctor Pain’)

and without anything in the log, some sound are not played entirely…
chan.play(‘Welcome to the office of’) → 90% of the time I can hear ‘Welcome to the office of’ but sometimes ‘Welcome to the office’ or ‘Welcome to the office o$%$$%#’ with $%$$%# a sound like if something is breaking…
and the next sounds are played normaly.

Anyone got this problem?

Thank you

On Monday 04 March 2024 at 14:48:38, meirjdd via Asterisk Community wrote:

Hi

I am using ari-client with nodejs.

During a call, I play multiple of audio files, for examples:
chan.play(‘Hello’)
chan.play(‘Welcome to the office of’)
chan.play(‘Doctor Pain’)

and without anything in the log, some sound are not played entirely…

  1. What log verbosity level are you looking at?

  2. What format are these audio files in?

Antony.


“How I managed so long without this book baffles the mind.”

  • Richard Stoakley, Group Program Manager, Microsoft Corporation,
    referring to “The Art of Project Management”, O’Reilly press

                                                Please reply to the list;
                                                      please *don't* CC me.
    

Hi,

  1. I open asterisk with rvvvvvvvvvvvvvv…
  2. I am playing WAV 8000Hz 1 Channel

Just a tip, if you are fed up of typing all those “v” characters, edit your asterisk.conf and change the verbose setting to, e.g.

verbose = 100

Now you don’t have to type any “v” characters at all.

thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.