Phones Cant Register Error Code 403

I Cant Register on Asterisk server ( from internet.
I get 403 Forbidden
Though i can register on local lan

i have forwarded to my router (dynamic DNS It works well)
now on the router ( i have fwd port 5060, 10000-20000 (TCP & UDP) to

My sip.conf is as follows

context=default         ; Default context for incoming calls
allowoverlap=no         ; Disable overlap dialing support. (Default is yes)
bindport=5060           ; UDP Port to bind to (SIP standard port is 5060)
                                 ; bindport is the local UDP port that Asterisk will
                                 ; listen on
bindaddr=        ; IP address to bind to ( binds to all)
srvlookup=yes           ; Enable DNS SRV lookups on outbound calls
                                 ; Note: Asterisk only uses the first host
                                  ; in SRV records
                                  ; Disabling DNS SRV lookups disables the
                                 ; ability to place SIP calls based on domain
                                    ; names to some other SIP users on the Internet
dtmfmode = rfc2833
externrefresh = 5
localnet =

Also every user has nat=yes and qualify=yes

Please Help


When you say from the internet do you mean a device with a real public adress or behind nat?


That device is also behind a nat
tries to register on

Can Anyone Help me Plz


So we are double natting. If you want to do this you realy need to have a real external IP on the asterisk server.


I thought you needed an IP for externip, not a URL?
if you have a site created through to do the dns forwarding then it should work, I do that with my system. Do you have the options for the extensions in sip.conf, nat=yes?


HAve a look at may go someway to solving the problem


Exact the same problem.

Using: Asterisk

Inside the LAN -> No problems
From outside -> auth denied

Client: Behind NAT, but according to STUN there should be no problems (I am able to connect to other SIP providers)

Server: Behind NAT, but I forwarded udp 5060, 10000-2000 to the servers IP


nat = yes

On an asterisk of my friend (exact same setup) it works, he is using the version (I tried his sip.conf, but it did not work for me)

I know it works, because there was one version (I tried 1.6, 1.6.1) which worked :smiley:

And ports are being forwarded correctly, as I can see the register attempt on servers sideā€¦