Phone at other end does not ring


#1

When I call with in my network, i.e. another extension, everything works well. When I place an outside call using the zap channel (TDM02B), the phone at the other end does not ring. I’m getting ring back tone so if they pick up the phone while i’m trying to call them, the call will be connected, but they do not get a ring.
Any one know the problem here?


#2

You have not posted enough information for anyone to make a reasonable assessment of what the problem may be. You should post your configuraiton and the output of a verbose CLI when you attempt to make a call to an external number.


#3

The debug information is below. The real outgoing number has been changed to “5551212” in this information below. Please let me know what other information I can provide.
Thanks!

===============================================

Asterisk CVS-Nv1-2-0-01/21/06-16:37:10, Copyright © 1999 - 2005 Digium.
Written by Mark Spencer markster@digium.com

Connected to Asterisk CVS-Nv1-2-0-01/21/06-16:37:10 currently running on localhost (pid = 31030)
Verbosity is at least 3
– Executing Macro(“SIP/2004-b13f”, “dialout-trunk|1|5551212”) in new stack
– Executing GotoIf(“SIP/2004-b13f”, “1?3:2)”) in new stack
– Goto (macro-dialout-trunk,s,3)
– Executing Macro(“SIP/2004-b13f”, “user-callerid”) in new stack
– Executing DBget(“SIP/2004-b13f”, “AMPUSER=DEVICE/2004/user”) in new stack
– DBget: varname=AMPUSER, family=DEVICE, key=2004/user
– DBget: set variable AMPUSER to 2004
– Executing DBget(“SIP/2004-b13f”, “AMPUSERCIDNAME=AMPUSER/2004/cidname”) in new stack
– DBget: varname=AMPUSERCIDNAME, family=AMPUSER, key=2004/cidname
– DBget: set variable AMPUSERCIDNAME to 2004
– Executing GotoIf(“SIP/2004-b13f”, “0?5”) in new stack
– Executing SetCallerID(“SIP/2004-b13f”, ““2004” <2004>”) in new stack
– Executing NoOp(“SIP/2004-b13f”, “Using CallerID “2004” <2004>”) in new stack
– Executing Macro(“SIP/2004-b13f”, “record-enable|2004|OUT”) in new stack
– Executing GotoIf(“SIP/2004-b13f”, “0 > 0?2:4”) in new stack
– Goto (macro-record-enable,s,4)
– Executing AGI(“SIP/2004-b13f”, “recordingcheck|20060130-103707|1138599427.10”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20060130-103707|1138599427.10: Outbound recording enabled.
recordingcheck|20060130-103707|1138599427.10: CALLFILENAME=OUT2004-20060130-103707-1138599427.10
– AGI Script recordingcheck completed, returning 0
– Executing Monitor(“SIP/2004-b13f”, “wav49|OUT2004-20060130-103707-1138599427.10| mb”) in new stack
– Executing Macro(“SIP/2004-b13f”, “outbound-callerid|1”) in new stack
– Executing DBget(“SIP/2004-b13f”, “USEROUTCID=AMPUSER/2004/outboundcid”) in new stack
– DBget: varname=USEROUTCID, family=AMPUSER, key=2004/outboundcid
– DBget: set variable USEROUTCID to 2004
– Executing GotoIf(“SIP/2004-b13f”, “1?4”) in new stack
– Goto (macro-outbound-callerid,s,4)
– Executing GotoIf(“SIP/2004-b13f”, “0?6”) in new stack
– Executing SetCallerID(“SIP/2004-b13f”, “2004”) in new stack
– Executing NoOp(“SIP/2004-b13f”, “CallerID set to 2004”) in new stack
– Executing SetGroup(“SIP/2004-b13f”, “OUT_1”) in new stack
– Executing CheckGroup(“SIP/2004-b13f”, “”) in new stack
– Executing SetVar(“SIP/2004-b13f”, “DIAL_NUMBER=5551212”) in new stack
– Executing SetVar(“SIP/2004-b13f”, “DIAL_TRUNK=1”) in new stack
– Executing AGI(“SIP/2004-b13f”, “fixlocalprefix”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/fixlocalprefix
fixlocalprefix: Could not parse /etc/asterisk/localprefixes.conf
– AGI Script fixlocalprefix completed, returning 0
– Executing SetVar(“SIP/2004-b13f”, “OUTNUM=5551212”) in new stack
– Executing Cut(“SIP/2004-b13f”, “custom=OUT_1|:|1”) in new stack
– Executing GotoIf(“SIP/2004-b13f”, “0?16”) in new stack
– Executing Dial(“SIP/2004-b13f”, “ZAP/g0/5551212”) in new stack
– Called g0/5551212
– Zap/1-1 answered SIP/2004-b13f