Outgoing on zaptel

Im trying to get my POTS line working on asterisknow. I can recieve incoming calls, and i can call extentions. Outgoing calls seem to be blocked automatically and not even making it to the server. I see errors when I restart Zaptel saying this.

[Feb 8 09:33:43] WARNING[2177] chan_zap.c: Unable to specify channel 1: Device or resource busy
[Feb 8 09:33:43] ERROR[2177] chan_zap.c: Unable to open channel 1: Device or resource busy
[Feb 8 09:33:43] ERROR[2177] chan_zap.c: Unable to register channel ‘1’
[Feb 8 09:33:43] WARNING[2177] chan_zap.c: Reload channels from zap config failed!

thats the first time i restart, the next time it seems to work but still no outgoing calls. I feel like im close, I was hoping one of you gurus had an answer to why this is happening.

Oh the card is a fxo X101P.

Thank you in advance for any help with this problem.

You say incomig works, so that means ztcfg is all good. Post a debug of an outgoing ZAP call. When you say it does not even hit the server, you man there’s not ouput on cli for the call? hmm, can you give more info?

Yes, Nothing happens on the server for an outgoing call, and on the sipphone I get an immediate busy signal no matter what number I dial.

The sipphone I’m using is a cisco 7960 with the 6.2 sip firmware.

Thanks for replying and bearing with me, this is all new to me.

Now I figure it’s this cisco phone, cause I downloaded a softphone and it works through that. Has anyone gotten the 7960 to work with asterisk now? I just tried upgrading the firmware to 7.4 but it still wont make outgoing calls.

could any one give me a suggestion about Linux OS that can working on zaptel. I have try SUSE-10, Fedora Core-6, Fedora Core-3, Mandriva Linux 2006, there are always error when compiling zaptel. I tried zaptel-1.2.5, zaptel-1.2.10, zaptel-1.2.13, and zaptel-1.4.0.


asterisknow does work, it was a config on the cisco phone. Hadda change natenable to 1

thank you for your info. I will find out