Outgoing calls - help


#1

Hello All
I have installed Asterisk and quadBRI witch BRIstuf. I have the phone line connected to 1 port.
Incomming calls work, but i can’t dial out.

Here is my config:

zapata.conf
[channels]
language=pl
switchtype = euroisdn
; p2mp TE mode (for connecting ISDN lines in point-to-multipoint mode)
signalling = bri_cpe_ptmp

pridialplan = dynamic
prilocaldialplan = local
nationalprefix = 0
internationalprefix = 00
usecallingpres=yes
echocancel = yes
echocancelwhenbridged = yes
echotraining = 100

context=isdn-incoming
group = 1
channel => 1-2
;channel => 4-5
;channel => 7-8

group = 2
;channel => 10-11

extensions.conf
[isdn-incoming]
;exten => _X.,1,Dial(SIP/phone${EXTEN},60)
exten => _X.,1,Dial(SIP/1,60,t)
exten => _X.,2,Dial(SIP/2,60,t)
exten => _X.,3,Dial(SIP/4,60,t)
exten => _X.,4,Hangup

; in sip.conf you put context=sip-phones so the phones can dial out
; using zaptel group 1 (which includes all BRI ports, see zapata.conf)
[sip-phones]
exten => _1,1,Dial(SIP/1,60,t)
exten => _1,2,Hangup
exten => _2,1,Dial(SIP/2,60,t)
exten => _2,2,Hangup
exten => _3,1,Dial(SIP/3,60,t)
exten => _3,2,Hangup
exten => _4,1,Dial(SIP/4,60,t)
exten => _4,2,Hangup
exten => _49,1,Dial(SIP/49,60,t)
exten => _49,2,Hangup
exten => _200,1,Dial(SIP/200,60,t)
exten => _200,2,Hangup

ignorepad => 8
exten => _8.,1,Dial(ZAP/g1/${EXTEN:1},60)
exten => _8.,2,Hangup
exten => _8.,102,Playtones(busy)
exten => _8.,103,Wait(10)
exten => _8.,104,Hangup

sip.conf
[general]
port = 5060 ; Port to bind to (SIP is 5060)
bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
disallow=all
allow=ulaw
allow=alaw
context=sip-phones
dtmfmode=inband
#include sip_nat.conf
#include sip_custom.conf
#include sip_additional.conf

i I wont to dial out, the log from Asterisk is:

chan_sip.c: Checking SIP call limits for device 49
chan_sip.c: build_route: Contact hop:
logger.c: – Executing Dial(“SIP/49-f543”, “ZAP/g1/0692406595|60”) in new stack
logger.c: – Requested transfer capability: 0x00 - SPEECH
channel.c: Avoiding initial deadlock for 'Zap/1-1’
channel.c: Avoiding initial deadlock for 'Zap/1-1’
channel.c: Avoiding initial deadlock for 'Zap/1-1’
channel.c: Avoiding initial deadlock for 'Zap/1-1’
logger.c: – Called g1/0692406595
chan_zap.c: Queuing frame from PRI_EVENT_PROCEEDING on channel 0/1 span 1
logger.c: – Zap/1-1 is proceeding passing it to SIP/49-f543
logger.c: – Channel 0/1, span 1 got hangup request
chan_zap.c: Set option AUDIO MODE, value: ON(1) on Zap/1-1
chan_zap.c: Hangup: channel: 1 index = 0, normal = 14, callwait = -1, thirdcall = -1
chan_zap.c: Not yet hungup… Calling hangup once with icause, and clearing call
chan_zap.c: disabled echo cancellation on channel 1
chan_zap.c: Set option TDD MODE, value: OFF(0) on Zap/1-1
chan_zap.c: Updated conferencing on 1, with 0 conference users
chan_zap.c: Set option AUDIO MODE, value: OFF(0) on Zap/1-1
chan_zap.c: disabled echo cancellation on channel 1
logger.c: – Hungup ‘Zap/1-1’
== Everyone is busy/congested at this time (1:0/0/1)
app_dial.c: Exiting with DIALSTATUS=CHANUNAVAIL.

Can any one help me, PLEASE


#2

No one can help me?
I fight with my asterisk all night and I give up.

Any idea what is wrong with my config, why I can’t dial out ?


#3

Please post ZAPTEL.CONF and the customized SIP conf files.


#4

Is this the error that you get when you want to call where ? To an internal extension or external ? It seems you dont have an extension for outgoing.

Have a look at this book h6315.com/ast_book/