Outgoing call to remote extention

I have successfully setup asterisk (elastix) and have set up 3 extentions
2 (1000, 1003) are in the same network as asterisk server and 1(1001) is remotely connected.
the 2(1000,1003) extentions are working great which are within the network, where as the remote extention is not.

Calls to remote extention from both the 1000 and 1003 are not going through where as calls from remote extention 1001 is successfully terminating on both 1000 and 1001.

Server ip is in DMZ hence dont think the issue is with NAT.

Please help me resolve this.

Thanks in advance

full log while making the call

[Nov 13 18:26:42] VERBOSE[3669] logger.c: – AGI Script dialparties.agi completed, returning 0
[Nov 13 18:26:42] DEBUG[3669] app_macro.c: Executed application: AGI
[Nov 13 18:26:42] VERBOSE[3669] logger.c: – Executing [s@macro-dial:7] Dial(“SIP/1003-0867f998”, “SIP/1001||tr”) in new stack
[Nov 13 18:26:42] WARNING[3669] rtp.c: Unable to set TOS to 184
[Nov 13 18:26:42] WARNING[3669] app_dial.c: Unable to create channel of type ‘SIP’ (cause 20 - Unknown)
[Nov 13 18:26:42] VERBOSE[3669] logger.c: == Everyone is busy/congested at this time (1:0/0/1)

it might be your nat, but it might be your conf too. could you post your config files? sip.conf, extensions.conf (if your users are elsewhere, post that too)

standard a phone can call but cant be called if its not noted in extensions.conf

Here is the sip.conf

[general]
;
; enable and force the sip jitterbuffer. If these settings are desired
; they should be set in the sip_general_custom.conf file as this file
; will get overwritten during reloads and upgrades.
;
; jbenable=yes
; jbforce=yes

; These will all be included in the [general] context
;
#include sip_general_additional.conf
#include sip_general_custom.conf
#include sip_nat.conf
#include sip_registrations_custom.conf
#include sip_registrations.conf

; These should all be expected to come after the [general] context
;
#include sip_custom.conf
#include sip_additional.conf
#include sip_custom_post.conf

Extentions.conf is too big to be posted , is there a way i can email you.

Thanks in advance

you can use a pastebin there are a few

straight from jbot on #asterisk

[~pastebin] A “pastebin” is a web-based service where you can paste anything over 3 lines without flooding the channel. Here are links to a few : rafb.net/paste

paste the files into one of these services and paste the link into the forum

Thanks for the update

This is the extensions.conf
pastebin.com/m3cdc9958

This is sip.conf
pastebin.com/m7ddeb37

sip_nat.conf
nat=yes
externhost=xxxx.gotdns.com
localnet=192.168.1.0/255.255.255.0
externrefresh=120

this is sip_additional.conf
pastebin.com/m754a26eb

sip_general_additional.conf
; do not edit this file, this is an auto-generated file by freepbx
; all modifications must be done from the web gui

vmexten=*97
bindport=5060
bindaddr=0.0.0.0
disallow=all
allow=ulaw
allow=alaw
context=from-sip-external
callerid=Unknown
notifyringing=yes
notifyhold=yes
limitonpeers=yes
tos_sip=cs3
tos_audio=ef
tos_video=af41

I succesfully setup a SIP trunk and is able to make and receive calls to all the internal extentions where as i can only make outgoing calls from remote extentions, incoming to remote extentions does not work.

Help me please to resolve this.

Thanks again
Mohammed
Please help me resolve this.