Outbound dtmf does not work, inbound does

My current provider - ViaTalk (pain in you know what may I add)

dtmf on providers site is set to rfc2833 (recently changed from inband). I have dtmfmode=rfc2833 and dtmf=rfc2833 in both general section and in peer description in sip.conf

Inbound dtmf (for my IVR) works fine. Outbound - in most cases will not allow any key passing. However… for some systems (i.e. Peoples Gas) - it works very well. For most outbound calls - it does not.
Another interesting part - after call routed to default destination (since I could not press anything) - people can not hear me (i.e. when call to CDW)

Another interesting thing… If I change dtmf in peer description only (leave the general section) to inband - outbound dtmf starts working but inbound stops, so my IVR would die.

Any thoughts or suggestions?

Just thought I’d throw my two cents in here. . . I am one of the two admins that implemented ViaTalk’s original system. We fought that outbound DTMF problem a lot and here’s what I know:

  1. The problem is that for some systems you need a different DTMF mode for Asterisk to properly talk to them (as in the ViaTalk server needs to change DTMF modes)

  2. I originally set up a feature code at ViaTalk back in 2005 (Around Nov) that would change the DTMF mode for a single call so that systems that did not work would have the needed mode and would start “hearing” your tones. I guess someone decided that didn’t need to be in there anymore…trust me there’s a lot of that kind of crap over there.

  3. From what I understand, ever since I left in 2006 and when the other original admin left shortly thereafter, it has gone downhill over there.

You may want to talk to ViaTalk about making sure you’re not set to canreinvite=yes, which could be causing your problem with outbound voice. I had that problem 99.99% fixed when I was working there, with 1 in a few hundred tickets complaining about it. Don’t know what changed there.

Also, YOU need to be INBAND probably, Asterisk to ViaTalk always performed best with the client machine running inband back when we launched them.

Quick additional note…have you tried setting the DTMF mode in the peer to inband and rfc2833 for the user entry? Just a thought that popped into my head
Just my thoughts, sorry you’re having trouble. I might add that it’s funny that these problems STILL exist…especially since I was the admin that got stuck with figuring out the solution to everything like this, and DID. The stuff I didn’t implement I at least emailed the other admin (after I left) and told him how to fix the issues or at least pointed him in the right direction.

Sherwood McGowan
Rushowr.com VoIP Solutions Consultants

Funny… It’s a small world after all. ViaTalk recently announced support for rfc2833. Switching to inband (tried it) is causing my IVR to stop working completely (while outbound works ok).

as far as canreinvite - I shall try it. I’ll check with Viatalk if it is possible to switch me over to canreinvite=no


No problem mate, glad I could offer some help.

ViaTalk has confirmed that they set me with canreinvite =no and dtmf=rfc2833

I changed on asterisk canreinvite in my peer description and now it recognizes numbers some time… actually rerely but it least it does something. Any clues of what else can be done would be greatly appreciated.

actually… no it became worth… the systems I was able to go through menu before now not working… :frowning:

I’d love to help but really it’s hit and miss. Like I said, they used to have a feature code that you could dial to swap DTMF modes on the fly (there’s a dialplan command in Asterisk that allows it). That’s the only thing I can think of other than just constantly troubleshooting the logical path of what’s causing each issue.

I’d be of more help if you had the issue on my system, but since I can’t make changes at ViaTalk to try fixing you, I’m limited.


I think I got it… I changed peer and general to do dtmf=auto. So far it works well on inbound and outbound. But you can not be so sure with ViaTalk… might stop tomorrow and they will start blaming Asterisk for this…

Thanks for your input

They can’t blame Asterisk…I can’t say why, but if you think about what software this forum is about and what I used to do for them, you’ll understand…nudge nudge hint hint