Outbound calls over TCP problem

Hi all,

I am new in asterisk,i tried to find a solution to my problem in the forum but unfortunately i couldn’t.
I would appreciate your help in this.
I have configured SIP trunk in my asterisk (version with an Avaya PBX.
Avaya supports only SIP trunking over TCP, so i configured the sip.conf of my asterisk like below:



Output of “sip show settings” command below:

[i]Global Settings:

UDP Bindaddress:
TCP SIP Bindaddress:

Default Settings:

Allowed transports: TCP
Outbound transport: TCP[/i]

The sip signaling of incoming calls to my asterisk works fine over TCP.

But when i try outbound call (e.g. bridge transfer), the INVITE message my asterisk sends to Avaya is over UDP? and of course it fails.

INVITE sip:20000@172.x.x.20 SIP/2.0
192.168.x.x:5060 172.x.x.20:5060 xVia: SIP/2.0/UDP 192.168.x.x:5060;branch=z9hG4bK6a71196d;rport

Could you please tell me what exactly is missing in my configurations and the INVITE message that my asterisk send to Avaya goes through UDP?


Not unless you tell us exactly what is in your configuration.

My guess is that you have specified the IP address directly in the dialplan.

Thanks David, you guessed correctly.

I had SIP/extension@IP, as soon as i changed to SIP/extension@trunk_name it worked