Out going calls SIP TO field


Guys first of all sorry for bugging you guys with so many problems this week

thanks for the help

i can’t make outbound calls, i think i have found the problem, asterisk isn’t sending a number to my provider see below

i dont get why not as the phone reg sends the number but then asterisk only forwards peering.2talk.co.nz to my provider

What version of Asterisk?

Are you using chan_sip or chan_pjsip?

If you bump up console verbosity to something greater than 2, what does your ‘dial()’ statement look like?

Your ‘dial()’ should look something like:


hello sedwards

version 16

chanp pjsip

== Setting global variable ‘SIPDOMAIN’ to ‘’
– Executing [080008388383@sets:1] Dial(“PJSIP/0000f30A0A01-00000003”, “PJSIP/itsp-no-auth”) in new stack
– Called PJSIP/itsp-no-auth
== Everyone is busy/congested at this time (1:0/0/1)
– Auto fallthrough, channel ‘PJSIP/0000f30A0A01-00000003’ status is ‘CHANUNAVAIL’

So, when I execute my dial statement, the console log looks like:

    -- Executing [test10@test-framework:4] Dial("SIP/poly-77a1-0000007c", "sip/619349xxxx@vtpv11:5060,10,r") in new stack

You are not telling your SIP provider what number to dial. If I were to guess (assuming the number you want to dial is 080008388383), your ‘dial()’ statement should look something like:


This depends on how ‘itsp-no-auth’ expects you to pass the DID. You may need to add a ‘+’ or trim some leading digits, etc.

For future reference, I (and I’m assuming others on this list) would prefer if you post a console log with verbosity > 2 and sip logging enabled rather than a Wireshark screenshot. Sometimes the surrounding context adds significant clues. Please remember to use ‘preformatted text’ tags so the forum software does not eat meaningful characters like ‘$’ and formatting.

thank you so much its working now

and thank you for that other info i will add it to my asterisk notes so i will remember for next time

have a wonderful weekend

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.