One way audio on external call with Asterisk and Avaya

Hello everyone,

I’m new to Asterisk and am having a bit of a problem. I have an Avaya system that connects to the PSTN. I have an Asterisk system in which I have a few SIP clients with both softphones (Zoiper) and actual physical phones (Aastra 6731i). I have established an H323 trunk between Asterisk and Avaya and from the SIP clients I can call the Avaya extensions and vice versa with no trouble. The problem begins when I try to make an external call from Asterisk.

If I make an external call from Asterisk, the external side can hear the voice from Asterisk, but on this side there’s no audio. There’s just one way audio and I don’t know why.

Both Asterisk and Avaya are on the same subnets. I have tried three diferent audio codecs (G729, G711 ulaw and G711 alaw) and all work the same.

I’m using Asterisk and here are the contents of my configuration files:

I hope you can help me out with this.

Thank you.

If you are new to Asterisk, you should not be using a version that is more than a year past final end of life. Use version 11 instead. If that still causes problems, we will need a SIP trace and the contents of sip.conf. Note some options have been renamed.

In the mean time, can you confirm that all the phones are on the same, NATed, sub-network (same broadcast area) as the Asterisk box.

All the phones and both the Asterisk and the Avaya are on the same sub-network.

I also tried with an IAX extension and the result was the same. The calls between Asterisk and Avaya are ok but when trying to make an external call there’s only one way audio.

I use version 1.6 because was the one being used on most of the tutorials I read. I’ll try to use version 11 and keep you posted.

Thank you.