[HELP] No Audio


#1

Asterisk 1.0.7 running can make calls to ext and can hear both ends of the conversation.

But when get a call from external line be zap or sip unable to hear the caller but they can hear me.

I have had on the odd call where I can hear the external caller but this is only 1 in every 100+ test calls


#2

There are only 2 ext on the server at the moment 200 and 201

from sip.conf

[201]
username=201
type=friend
secret=4768
record_out=On-Demand
record_in=On-Demand
qualify=no
port=5060
nat=never
mailbox=201@default
host=dynamic
dtmfmode=rfc2833
context=from-internal
canreinvite=no

would it be somthing todo with the audio codec ???

Using Grandstream IP phones I have also tested with firefly and get the same results


#3

I have the same issue as stated above.
I have installed Asterisk@Home, created 2 extensions for 2 SIP Phones.
When I try to call from one to the other, the second phone is ringing (in both ways).
I pick up the phone, and no sound from both !

I have activated voice recording,
and I can get Wav files with my talking inside !

I have used ethereal to check from Asterisk the traffic,
SIP trafic seems allright. G711MU codec is used.
using “Anylize”, I can even recompose the RTP trafic …
Once more, I can hear my talking !

I have activated Asterisk console,
no error message showing up.

So somehow, no Audio !

Any Help would be welcomed !

Thanks,


#4

I forgot to add something more …
When I did a trace with Ethereal …
I only see traffic from the Phones to Asterisk !
no traffic back …

Is there a way not to pass through Asterisk if there is no recording ?

Thanks once more for your help !


#5

Actually, I was using a Swissvoice Phone with firmware SIP v100_b3 …
I tried another SIP Phone … “GrandStream / Budge Tone 100” … and it worked perfectly !

So I suppose, the issue came from the phone … why, I don’t know !
I checked the codecs and everything …
and eveything seemed to be allright !

Anyway, I hope this will help somebody in the same case !

Ciao


#6

Did some playing around and got it working, i needed to add
externip= My ext ip adress