One Touch Recording with automon; recording will not start


I’ve looked through the forums and online for information regarding on-demand call recording. There is information available but none of it has worked for me. The feature automon configured in features.conf and extensions.conf appears to be the most commonly used. I have enabled it on our instance and tried a variety of configurations, but can not get a call to start recording. From the CLI prompt, i’m able to see that the One Touch is enabled against *1 using “show features”.

Here is my setup:

Asterisk Version: 1.4.23

automon => *1
featuredigittimeout = 2000

exten => 804,1,Dial(SIP/${EXTEN},wW)

When i place a call and dial *1 during the call, I get no indication that the call is recording, and nothing appears in the /var/spool/asterisk/monitor folder. I enabled dtmf logging in the logger.conf, and I can see the DTMF digits being dialed in the logs. I have also tried increasing the featuredigittimeout as this appeared to be the source of problems for many people. Didn’t help. I’ve also tried using the Set(DYNAMIC_FEATURES=automon) instead of using the global DYNAMIC_FEATURES - that also had no impact. I have both reloaded the full configuration through CLI prompt and restarted asterisk.

Any idea what might be missing from this configuration?

Thanks in advance.


please check if automon feature is configured properly with the following Asterisk CLI command:

also - please post all your feature.conf files as you have to put automn into the [featuremap] section (as mentioned in