Not all DTMF's recognised


#1

Hi, I have been trying for several days to get DTMF tones working correctly. All keys are recognised by Asterisk (e.g. for retrieving voice messages), but the number ‘3’ is ignored on external PSTN calls. All other keys seem to be OK. I have tried different SIP phones, an analog phone, different dtmf signalling modes, relaxing dtmf tones, banging my head on the desk, and I always get the same result. ‘3’ is ignored.

Does anyone have any ideas (apart from a helmet!)? I have a TDM11B card in my Asterisk server.


#2

I tried another approach last night as I thought it might be something to do with txgain. ztmonitor shows that the TX gain is going to maximum on key-presses even though I have been told that my voice is ‘quiet’ by called parties.

When I tried decreasing txgain levels, I was no longer able to hear the called party (even though a connection had been made).

Does anyone have a zapata.conf file that they can share, that is working in New Zealand for TDM11B cards?


#3

In zapta.conf you whould change relaxdmtf=no to relaxdmtf=yes, this worked out for me i hope it will work for you :smile:. BTW you mentioned you decrased the sound. can you please tell me where i can increase or decrease the sound? please send me an email to trimitrimi@hotmail.com