No voice when connecte from outside the LAN

I installed Asterisk on a Raspberry PI 4 with a 3G dongle to connect a sip client with cellular line.
I use MIZUDROID as the client software.
When I connect from the same LAN it works excellent - I can get calls and it works as I wanted.

When I am outside the LAN - I use a private VPN to connect to my line (base on wireguard).
When I use the VPN my cellular phone can access other computers on the LAN and as an internal IP.
When I run MIZUDROID it says it is registered - and If I call the SIM number of the dongle I get the call in MIZUDROID including caller id. I can also answer - But the issue is that there is no voice.
I can’t hear the other side and he can’t hear me.

Any suggestion ?

Which channel driver are you using?

What are its public address and local network settings?

Sorry but I don’t know what is channel driver.

About the second question - I guess you mean in the General SIP settings ?
I just saw that they are no set
Because I am using VPN - I guessed that my phone is inside the LAN - and it works when connected with wifi - shouldn’t it work also from outside with VPN ?

I don’t want to open ports in my router except the wireguard vpn port.
Is there any reason I should set the external address and local networks in the NAT settings in General SIP settings ?

There is no such thing in Asterisk. Are you using some GUI? If so, please use the forum for the GUI, e.g. for FreePBX.

Channel driver refers to anything in the channels directory in the source code, e.g. chan_dahdi, chan_skinny, chan_iax, chan_sip, chan_pjsip, etc., etc. There are two channel drivers for SIP, of which only one is currently supported, chan_pjsip.

New to Asterisk and still get confuse with the right notations

I am using chan_pjsip

What does Asterisk do with the public address and local network ?
How does it influence its behavioral ?

If there is a public address for signalling, and the destination isn’t on a local network, it sets the addresses in the Via and Contact headers to the public address, rather than the address of the interface used. With a public media address, it does the same except for the media address.

If you have a public address but fail to list the VPN as local, the public address will be, incorrectly, used for traffic over the VPN.

I did my homework - and local network wasn’t defined and the public address was wrong.
I updated it and now it works !!

As all access from outside is with VPN - I guess I don’t need public address and only local network is important ?

I also defined iax2 extension - and it also works - I think iax doesn’t need this local network definition ?

The strange thing is that I wanted to check it again - so I removed the local network and it still works
But I can’t complain as the goal achieved.

Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.