No Such Command - sip show peers

I have been searching the forums but can find no reference to the issue that I’m having:

I did a clean install of [color=orange]AsteriskNow 1.5.0[/color] - installed OK - updated / upgraded everything possible through FreePBX Tools - Module Admin. Now stands at Asterisk version and FreePBX Core version 2.6.0RC2.1 - I have configured the extensions, a trunk and a Outbound rule - however my problem is that I cannot run ‘sip show peers’ or any other sip commands from the CLI or from within FreePBX.

I have two messages in the FreePBX System Status - ‘retrieve_conf failed, config not applied’ & ‘Asterisk Manager Connection Failure’ - these are from yesterday when I installed.

Any assistance would be grateful - step by step please as I’m not a linux person. The idea is to get this working and then migrate users from an early Asterisk system (version 1.2.10) - Thanks in advance.

I ran into this too. I had to create a sip account from the web page, then run “amportal restart” from the linux command line. After that, the sip module loaded and “sip show peers” began showing the sip accounts.

Hope this helps,

Hi David - thank you very much for your reply - I have been having a look since and have not managed to solve the problem. :frowning:
I believe that I have configured a SIP account (Trunks - Add Trunk) and I have configured a route to make use of it but still no joy on the ‘sip command’ front.
Also, following the running of the suggested command I receive the following messages back:

[size=85]Stopping Asterisk
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)
Asterisk Stopped
Stopping for Server
FOP Server Stopped
Setting File Permissions
Permissions OK
Starting Asterisk
Asterisk Started
Starting FOP Server
FOP Server Started

I am concerned also that two files in our original working system do not appear in the new file system as yet - namely sip.conf or extensions.conf.
I would have expected these files to have been created via FreePBX somehow. :unamused:

Is there any log files that I can review that will tell me what is going wrong / what is happening etc.
I have noticed that I have managed somehow to post this in the [color=#FF8000]Asterisk[/color] forum whereas it should be in the [color=#FF8000]AsteriskNow[/color] forum - apologies for this.
Your help is much appreciated.

What if you try to create a SIP extension (instead of a trunk) from the web page, then try the “amportal restart” command. Also, verify that you are submitting it, then applying the changes (the orange bar at the top of the screen). When you hit that, another box pops up and asks if you want to continue.

Hi Dave - Bingo!
Thanks again for your reply…
I had already created the SIP extensions - and had been ‘submitting’ all the configuration changes as I went along.
What I hadn’t noticed was the orange bar at the top prompting me to ‘[color=#FF8000]Apply Configuration Changes[/color]’ - doh!
This is obviously the ‘hidden’ interface to Asterisk as a lot of new files have now been created in the asterisk folder including variations of those mentioned earlier.
Now I can start playing…
Thanks again!