No sound on incomming calls from public

Hello, i have a problem and i really need your guys opinion on that. any idea will be apprecaited.

I have Asterisk 1.4 and here is the problem. When i call from regular phone to a phone in my network, i cannot hear what they are saying, and they can hear everythig.

When I call from one ext. to another - everything is fine. I already tried everything and nothing worked.

I tried to switch voip provider to a different server with AsteriskNow and everything works (with the same sip.conf and ext…conf)… So it has to be an Asterisk 1.4


anybody? this has to be a very stupid question or very hard… i’m guessing stupid…lol

You can clarify what is a “regular phone”. Is that a Zap channel in your server? Or is it someone calling from PSTN to your ITSP?

regular phone is the phone not connected to my pbx, let’s say my cellphone. everything connected with SIP (voip provider, and my phones)

One more thing i just found out, that if i call from my cell and leaving a voice message, then i can hear. so nothing wrong with voip provider and iptables… so it leaves me with sip.conf i guess… please give me any opinion becuase i really tried everything…



[quote=“bellorusha”]When i call from regular phone to a phone in my network, i cannot hear what they are saying, and they can hear everythig.

You still haven’t described your system very clearly. What is “a phone in my network”? How is it configured? Relevant fragments of config files would be helpful. (And if you suspect something in sip.conf, you’d have to explain.)

phone in my network - is voip phone connected to my asterisk over SIP.

Have you tried disallowing all codecs and then allowing only one, firstly ulaw or alaw, as they are the standard for PSTN.?
I had a problem in Asterisk 1.4.1 that didn’t have in AsteriskNow: all bridged call between my SIP phones connected to the * server and telephones outside connected through my VoIP provider had no sound. Had to choose the canreinvite=no option.

to disable all codecs and allow only alaw and ulaw, was my first idea… but it did not help…


thanks to you, i found it… the sip.conf with my provider was with “canreinvite=yes”… i changed it to no and everything works… o my god… thank you so much…

That’s great. My doubt now is if in AsteriskNow canreinvite=no is the default or not or if it is something else.