No sound between callers

Hello there, I am having issues with getting sound on calls and Asterisk is automatically hanging up on me. I am behind my router, the people I am attempting to call/who are calling are me are doing so from their softphones (extensions). One of the extension users was able to hear me but I could not hear her. Another could not hear me and I could not hear him.

This has been an issue since I have changed ISP. I have set port forwarding up on my new router. I have disabled my firewall to check if this was the issue. I have a static ip.

I am not sure what else to add other than a debug log which includes RTP. All of the settings within freepbx where NAT is concerned are set to NAT on/enabled.

This is a debug log - I am 048665 the remote user (the other side of my router) is 048663.

I’d be grateful for any help, please, if you do reply, subscribe to the thread as otherwise I get one response (usually a question) and then when I reply who ever responds to the problem then doesn’t see my reply :smile:

Sorry the pastebin is rather long but I figured that someone can use find to locate keywords of what they are looking for and that more info might help :smile:

Thanks and Kind Regards,


Hi Beanie, since you are using Freepbx people in here will redirect you to the official freepbx’s forums.

As always I ask this things when people use Natted extensions.

-Did you configured the externip?
-Did you configured the localnet?
-Did you configured the Nat settings for the remote peer?
(all setting in advanced sip settings .menu).

I can’t check the debug due to an issue with my mobile, but your pbx’s firewall allow the connection? The debug show retransmission issues?

Hello Navaismo,

Thank you for your reply.

The external IP is configured within Free PBX and is set to Static as I have a static IP address, this is also set within the asterisk files. I have also updated the DNS Server (primary and secondary) settings. Could you list the files within CentOS that need to be up to date please just to rule out any issues here?

NAT Settings within FreePBX advanced sip settings, and within the extensions is set to on as both parties (one of which is myself) are behind routers. Port forwarding has been checked and is operational on the correct ports for my router. I am of the understanding the remote user doesn’t need them although one party I have tried calling has port forwarding set up, the other doesn’t but I used to be able to connect calls with her.

I have tried taking the firewall down as this was the simplest way including flushing the iptables.

Local net automatic configuration has already been actioned.

One of the channel users thinks the issue is however related to a hairpin NAT issue although i’m not sure this is the case since NAT settings are configured properly…

Thanks again.