No DTMF On SIP Outbound

My set up is that I’ve got a Zoiper softphone registered to my Asterisk server. If I place a call from Zoiper in to Asterisk, DTMF is picked up with no problems. However, when I originate a call from Asterisk to the Zoiper phone, Asterisk never registers the DTMF signals.

Here is my sip.conf:



I have tried setting dtmfmode to rfc2833, info and inband with no change in results.

Zoiper is set up to use rfc2833 and I’ve also tried info and inband with it with no joy.

I don’t know where I need to go from here with this.

You have to put the line


into the extension no in [general]

Actually, in this case, it turned out to be a problem with the version of Zoiper I was using. I upgraded and everything started working properly.

I have a similar problem, my asterisk version is I’m working on a callback application.
The problem is, that if I connect to asterisk with a sip client soft phone, or with a DID, the asterisk correctly hears, recognizes DTMF. But, with callback, i tried 2 variation, one is with callfiles. So i create a callfile, put it into outgoing spool, asterisk calls me, and connects to the desired extension, which NOT hears the dtmf. Then, tried via asterisk manager Originate command, asterisk calls me back, connects to the very same extension, and then it hears dtmf.
So the only way, when it not works, when i start the call with a callfile :frowning:
In all cases, the same outgoing trunk was used, and i called always the same number, and was connected always to the same context, where I have the Read() cmd. which says “User entered nothing”. Tried all variations of dtmfmode in sip.conf general, also at the outgoing trunk settings, and also in asterisk before dial i use the SetSIPDTMFMode().
Any idea?
Thanks in advance,