No application 'ResponseTimeout' | no DigitTimeout Solved


I have a 1.4.8 system running on Centos 4.5 using SIP only (no telephony interfaces) This has been in production for six months and generally work great EXCEPT

I cannot get the applications ResponseTimeout or DigitTimeout to work. I keep getting the error

[Jul 21 15:35:08] WARNING[6129]: pbx.c:1797 pbx_extension_helper: No application ‘ResponseTimeout’ for extension (dialext, s, 3)
== Spawn extension (dialext, s, 3) exited non-zero on ‘SIP/213-09d7c050’

or the DigitTimeout variation of it

This has never worked. I have been upgrading since 1.4.0. Today I sat done to try and figure this out. I recompiled zaptel, libpri, and asterisk with the most current stable versions. no luck.

ztdummy is loaded; meetme works well
asterisk.conf correctly points to the right modules directory
core show applications shows 161 other applications that the ones I am looking for.

I am not finding any clues in the logs or in the forums. this has to be something simple, but I do not see anything relevant in the forums or logs

Anyone else that had this problem? Any pointers on where else to look?

I read the UPGRADE.txt file more carefully and discovered:

AbsoluteTimeout, DigitTimeout, ResponseTimeout, SetLanguage, GetGroupCount, and GetGroupMatchCount were all deprecated in version 1.2, and therefore have been removed in this version. You should use the equivalent dialplan function in places where you have previously used one of these applications.

I am not sure what the equivalent dialplan function is, but that is a different problem

You can try use Set(TIMEOUT(absolute)=n) or Set(TIMEOUT(digit)=n); for information about the TIMEOUT() function type “core show function TIMEOUT” in the * cli.


What are the replacements for those commands that have been removed?