No application 'AGI'

Hi guys
I haven’t been developing anything for Asterisk for a long time.
Now, I installed Asterisk 16.5.0 on UBUNTU 16.04.
I am trying to run an AGI that I had developed a long time ago but always get (see details below):
WARNING: …: No application ‘AGI’ …
The extensions.conf in this case looks like this:


exten => 301,1,NoOp()
same => n,Answer()
same => n,AGI( scriptAGI )
same => n,Hangup()

When I disk 301 through xlite I get the following:

[Aug 25 11:13:31] == Using SIP RTP CoS mark 5
[Aug 25 11:13:31] WARNING[6788][C-0000000d]: pbx.c:2922 pbx_extension_helper: No application ‘AGI’ for extension (inbound, 301, 3)
[Aug 25 11:13:31] == Spawn extension (inbound, 301, 3) exited non-zero on ‘SIP/asusXlite-0000000c’
[Aug 25 11:13:45] WARNING[1238]: db.c:348 ast_db_put: Couldn’t execute statement: SQL logic error or missing database

I believe this is a configuration issue. Can someone help me?
Thank you in advance

Have you installed the AGI module? Have you ensured that it is loaded? What happens when you try to manually load it?

Try loading

This solved the issue…
I actually had “load” in modules.conf, but it didn’t load. When I ran “load” from the Asterisk console, I got the information that was missing. Just load both and AGI started working. Thank you very much…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.