Agi:// ? - SOLVED

I am trying to install asterisk 1.2.5 whit astguiclient/vicidial, and it uses a lot of specials in the extensions.conf-file that i don’t understand. I now got it posible to call out from the system, but when i call in to the system i get this message in asterisk-commandprompt:

Does anyone seen anything like this before? I have never seen “agi://”, what does that mean? Do someone have a solution?

-- Executing Dial("SIP/0850007954-08182770", "SIP/s@SIPtrunk") in new stack
-- Called s@SIPtrunk
-- SIP/SIPtrunk-081b9f60 is circuit-busy
== Everyone is busy/congested at this time (1:0/1/0)
-- Executing Playback("SIP/0850007954-08182770", "invalid") in new stack
-- Playing 'invalid' (language 'en')
Apr 25 17:41:27 WARNING[16469]: file.c:587 ast_readaudio_callback: Failed to write frame
== Spawn extension (default, s, 2) exited non-zero on 'SIP/0850007954-08182770'
-- Executing DeadAGI("SIP/0850007954-08182770", "agi://") in new stack
Apr 25 17:41:27 WARNING[16469]: res_agi.c:210 launch_netscript: Connect to 'agi://' failed: Connection refused
== Spawn extension (default, h, 1) exited non-zero on 'SIP/0850007954-08182770'

I solved this problem with asterisk/vicidial. The problem was in extensions.conf (my version was from conf_example that came with astguiclient/vicidial 2.0.2) on lines 113-118. De FastAGI was only made for users with multiple server.

Now i got other problems, i’ll come back :smile:


Executing DeadAGI("SIP/gs102-081be2e8", "agi://") in new stack
Apr 26 15:01:19 WARNING[4919]: res_agi.c:210 launch_netscript: Connect to 
'agi://' failed: Connection refused


; FastAGI for VICIDIAL/astGUIclient call logging
;exten => h,1,DeadAGI(agi://
;exten => h,2,DeadAGI(agi://${HANGUPCAUSE}-----${DIALSTATUS}-----${DIALEDTIME}-----${ANSWEREDTIME}))
; Standard AGI for VICIDIAL/astGUIclient call logging
exten => h,1,DeadAGI(call_log.agi,${EXTEN}) ; DeadAGI is new
exten => h,2,DeadAGI(VD_hangup.agi,PRI-----NODEBUG-----${HANGUPCAUSE}-----${DIALSTATUS}-----${DIALEDTIME}-----${ANSWEREDTIME})