Newbie web admin access question

Hello all,
sorry I really have tried to sort this out myself but with no success.

I’m running ubuntu -

I installed Asterisk from packages using apt -

I installed asterisk-gui from source using svn to retrieve the latest today.

My http.conf looks like -

My manager.conf looks like -

So, I restart asterisk and all seems fine. If I access localhost:8088/asterisk/httpstatus
I get

But if I try to access the setup for the admin interface (localhost:8088/asterisk/static/c … stall.html)
I get

I am not prompted for any login.

Can anyone give me any advice as how to debug this (I can’t find anything useful in any of the logs) or offer any suggestions as to what may be wrong.

Thanks, wanderer.

Update 1653 14.04.08

Still working on it but still no luck.

I have tried binding to my local ip address, and in the manager.conf file.

All accesses whether to … basic.html

result in the same 404 error and the ‘nothing to see here’ message from asterisk. Any assistance would be greatly appreciated as I’ve spent four days banging my head against a wall so far.

Thanks, wanderer.

Hello 404wanderer,

I’m having the exact same problem. I’m trying to setup on ubuntu JeOS 7.10. I have no problem installing asterisk and the zaptel stuff, ( as mentioned on the ubuntu wiki , theres mentions 6.06 but all the steps work for 7.10 and 8.04).
After following almost every step you’ve mentioned, (tried both checking out the trunk and branches from the svn), I get the same issue.

I’ve tried some stuff, just to make sure the files were there and searchable, like pointing apache to /var/lib/asterisk/static-http and i can browse the pages, but of course, when it goes to submit its data via the extensive AJAX to rawman, I get the 404 there ( which is expected, i’m not sure how to redirect those requests to the listening application for the response )

I’ve also waded through some of the mailing lists which describe our problem exactly,

using sudo chown -R asterisk.asterisk /var/lib/asterisk/
even sudo chmod -R 777 /var/lib/asterisk ( just to rule out permissions… horrible idea )
even starting asterisk as root. each one shows the same info in /asterisk/httpstatus the only URI listed ( in the CLI with command “http show status”) i cant seem to access is /asterisk/static/

I’m pretty much out of ideas as well.

I ended up caving and just installing FreePBX, which is okay, but really lacks the functionality of the Asterisk-gui.

I would have probably just used the AsteriskNOW pre-packaged ISO, but when i try and install it in Virtualbox, it crashes… the AsteriskNOW beta installs fine but 1.0.1 and 1.0.2 both crash on boot-to-install

Thats all I’ve got for now. sorry i couldn’t be more help. I’ll probably keep tinkering away at it at home, but i cant waste any more hours on it.

Be sure to post if you find a solution, I’d love to hear it. I’ll do the same

I used “sudo apt-get install asterisk” as well… and I’m wondering whether that may be a problem too… I’ll try building asterisk from the SVN as well and see if it helps


Well I lied…

I did waste more time at work… and man did it pay off.

I found on post in a asterisk-gui install howto ( which I’ll bet $0.05 you saw too ), but i’d skipped the answer to our problems.

in his post blabla writes:

[quote]blabla (jmartin at voila dot fr)
24 January 2008 08:43:02
If make checkconfig is OK,
if Asterisk CLI command “http show status” gives good results
but then the request
adresse_IP:8088/asterisk/static/ … basic.html
gives 404 not found,
you may have a problem of directories ( in my case, html files in /var/lib/asterisk/static-http but mini http server uses /usr/share/asterisk/static-http )[/quote]

so I just deleted the static-http folder under /usr/share/asterisk and did a softlink to the one in /var/lib/asterisk/

sudo ln -s /var/lib/asterisk/static-http /usr/share/asterisk/

and BAM its working like a dream.

let me know if this helps you, fixed it on my end


Give that man a round of applause.

Cheers Jop that worked a treat. I’d given up after a week of getting nowhere.


wanderer. :smiley: