Newbie Needs Help Dialing Out

Greetings all. I’m an asterisk newbie and I’m just getting my feet wet. I’ve got asterisk up and running, my peers (2) are registered as is my SIP trunk to my provider. I can dial between extensions, but I cannot dial to the outside world. My sip.conf is as follows:
register => []




My extensions.conf is as follows:


exten => _1NXXNXXXXXX,1,Dial(SIP/{TECHPREFIX}{EXTEN}@flowroute)
exten => _NXXNXXXXXX,1,Dial(SIP/{TECHPREFIX}1{EXTEN}@flowroute)
exten => _NXXXXXX,1,Dial(SIP/{TECHPREFIX}1{AREACODE}{EXTEN}@flowroute) exten => _011.,1,Dial(SIP/{TECHPREFIX}${EXTEN:3}@flowroute)

include => outbound-long-distance
exten => 1000,1,Dial(SIP/1000)
exten => 1001,1,Dial(SIP/1001)


I know it’s something simple, but I am entirely new to this stuff and I have nobody to turn to but this community. Can anyone help me simply just put in place a dial plan to dial a number on the PSTN? TIA

Please provide a call trace when you try to dial out. What’s this TECHPREFIX for? Looking at your dialplan, I envision the call flow looking something like this:

User dials 15552223244
Dialplan matches to exten => _1NXXNXXXXXX,1,Dial(SIP/{TECHPREFIX}{EXTEN}@flowroute)
Asterisk tries to dial SIP/1234567815552223244@flowroute
Does flowroute know what to do with that? It’s not a number that it can just dial onto the pstn with (it might try but the result would likely be something like dialing 2345678155 and dropping the rest of the digits)

Thank you for the reply. Here’s what I see on asterisk when I try to dial from an extension to a PSTN phone…

Using SIP RTP CoS mark 5
[Sep 17 14:45:39] WARNING[9405][C-00000001]: channel.c:6147 request_channel: No channel type registered for ‘
[Sep 17 14:45:39] WARNING[9405][C-00000001]: app_dial.c:2578 dial_exec_full: Unable to create channel of type ‘’ (cause 66 - Channel not implemented)
== Everyone is busy/congested at this time (1:0/0/1)

TECHPREFIX is my UID that flowroute states to put in the conf file.

Also, since you’re just starting out. You should consider PJSIP instead of chan_sip. Base functionality is the same, configuration is a bit different (and in many ways cleaner). Also, if you’re going to stick with asterisk for a while it’ll prevent you from having to learn chan_sip and then pjsip as the latter is meant to replace the former. source:

Also I recommend you pick up the 5th edition of Asterisk: The Definitive Guide if you are interested in more than just setting up a simple pbx once. Has lots of good info.


This is confused because you haven’t escaped your dialplan code for the forum, by marking it as preformatted text.

The immediate error is exactly what is says in the message, you haven’t specified a valid channel type in the Dial for _1NXXNXXXXXX. OUTBOUNDTRUNK needs to start with “SIP/”.

The section heading for [flowroute] is missing.

As noted, newbies should be using PJSIP.

Suggested configurations from service providers usually contain a lot of bad practice and that is the case with yours. Please use type=peer, unless you have a specific problem that needs friend. Please use directmedia, rather than the obsolete name canreinvite. Please don’t use isnecure=port unless you have a specific need; consider using remotesecret instead of insecure=invite. There is no point in using allow without doing something to disable the default of allowing everything.

You have a strange configuration if your local devices are outside inside NAT, but the PABX is not.

Well, after adding the SIP prefix to OUTBOUNDTRUNK, I get an entirely different message:

Using SIP RTP CoS mark 5
== Using SIP RTP CoS mark 5
[Sep 17 16:53:51] NOTICE[15708][C-00000001]: chan_sip.c:24288 handle_response_invite: Failed to authenticate on INVITE to ‘;tag=as28189dd2’

You supplied a literal domain name without any authentication data, so that is not surprising. What was wrong with the outgoing context.

Also, including things that can generate chargeable calls in your default context is not normally a good idea.

Sorry for the delay, but I figured it out a few days ago. The problem wasn’t on the Asterisk end, it was the SIP trunk provider. I had my DID routed with IP authentication. When I set it to SIP registration, it immediately began working. :slight_smile:

Thank you all for the direction and suggestions.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.