Network Card Driver Problem

am having problem with my NIC driver.
i have one PCI dedicated for digium FOX 4 ports analog card.
i newly installed AsteriskNow 5 beta.
the problem is my network built-in is not detected on the system.
it happened lots of times on new featured desktops, (HP compaq this one)
i had to fix a PCI NIC card and do clean installation, so i can get the PCI works.
but i still have a problem with downloading and installing the built-in NIC.
please i need permanent solution for all desktops that i will (in future) install.
looking forward for a solution :smile:

Just an Asterisknow virgin. Tried loading the asterisknow software and all loaded Ok but no network. read a post from a couple of years ago and found some advise that worked for me. Try disabling your paralell port and audio port in bios and see if it comes back online. Mine did. Haven’t got to the point of finding out which one but glad to have it going

Some times if the computer is a new model the integrated network card is not recognized by Linux, you need to search in the manufacturer site for a driver to compile it. I had some similar situation with a HP Proliant Server, too the SATA DVDROM did not was recognized and i had to install Linux from a usb drive and download and compile the drivers for the Marvel integrated Network Card.

Good luck.