Need 180 Ringing signal instead of 183 Session in Progress


I have the following system.

A2Billing 1.4-RC1
Asterisk 1.4.24

We have a customer reporting that they were getting “183 Session Progress” signal instead of getting “180 Ringing” while making calls. And the customer expects the 180 signal rather than 183. Then i have checked for myself and found the same.

How do I configure in such a way i receive 180 signal instead of 183.

Can someone please advice me on this.


Don’t try and send in band progress indications.

Asterisk will send a perfectly good 180 Ringing, if you use it in a straightforward fashion, so we need to see your dial plan, and probably a verbose CLI trace of its execution, to see why you are getting 183.

It may well be sending 183 because of what what is downstream is sending. So we need to know what is downstream.

if you use the r option in the dial command it will send a 180.

But as the documentation says, it should not normally be needed. If he is getting 183, he is doing something unusual.

What “r” seems to do is to stop a 183 received from downstream being propagated back, but, if the downstream system is using in band progress, that may mean the caller never knows why the call fails, as they will never receive voice announcements about the failure reason.

It’s always best to use 183 but vinod said that his client wanted the 180 and not the 183.