Music on hold and /dev/null

Hello all,

We have just upgraded to 1.4.20-rc1 to resolve a manage redirect issue and found that the following method to turn off music on hold no longer works, it just reverts to the default moh class which we use for our IVR. Basically we are trying to turn off the MOH for agents and even playing a silence sound file produces noise on the line that you can hear in a quiet environment.

Does anyone have any other suggestions to completely stop playing a file for moh?

This is how our original moh class was configured

[none]
mode=files
directory=/dev/null

Thanks in advance (fingers crossed)