Moh not playing randomly

Ok here is my issue, i am running an Asterisknow setup based off the 1.4.18 release of asterisk. I’ve been able to pretty much get asterisk to do whatever i need it to, EXCEPT play the audio files in my moh directory randomly. What is weird is that initially it seems to pick what file to play by random(as in not the first file in the moh directory) however it will ONLY play that file until i change the files name and restart asterisk.

here is what my musiconhold.conf file looks like…

;! Automatically generated configuration file
;! Filename: musiconhold.conf (/etc/asterisk/musiconhold.conf)
;! Generator: Manager
;! Creation Date: Wed Oct 15 16:22:15 2008
mode = files
directory = /var/lib/asterisk/moh
random = yes

i know i must be missing something painfully obvious but for the life of me i can’t figure out what it is. I would like to avoid streaming music for moh, but if that is the only solution i guess ill have to settle.

ANY help is appreciated, thank you for your time.


i dont neccisarily need an exact answer for this, if someone could just point me in the right direction that would be fine. Maybe some tips on common mistakes in setting up music on hold or steps other people took to get they’re music on hold to play randomly. If you need any further information regarding my asterisknow install ill be more than happy to get it for you




what you have looks correct but try



Thank you for the reply Ian.

I tried without the spaces and it didnt seem to change anything.
(I did restart asterisk after changes where made)


The network switch that the * server was connected to crapped out last weak which caused huge headaches for us since I initially thought it was a problem with the * server before we realized the switch was shutting off every 3 seconds. To make a long story short I made a lot of frantic changes to the * server trying to fix the problem and now somehow music on hold plays randomly.

I did reboot the * server several times but i don’t believe this to be the reason MOH started playing randomly since i have tried that before.

Anyways music on hold works for me now, so problem solved, lol.