Mistery: No external audio after I've turned g722 on once

I have number of Yealink T21P E2 phones.
We decided to turn HD voice inside out LAN. I’ve added some settings to two extensions:


Everything worked fine, in HD, but a new problem arisen - no sound if I make external calls via one of two of our uplink trunks.

I’ve returned settings back. Nothing. Reset the phone. Nothing. Tried softphone. Nothing. Recreated the extension. Rebooted the server. Nothing nothing nothing. Played with nat and directmedia settings. No effect.

So, I currently have a mistrerious problem - phones, for which codec was briefly changed to g722 only, get no sound if they make external calls via one of external trunks.

I ran wireshark analysis, I now I see that some trouble occurs when “sick” phone is talking to my asterisk server.

Settings and phones are identical. One works, another does not.

…problematic RTP is sent from port above 20000. Is that ok?

Incoming media can come from any port number at all. The other side chooses the port. Your firewall should be configured accordingly.

My firewall may be blocking ports above 20000, I will double check.

Also, why 183 is not sent?