Missing CallerID on b410p

Hi,

We’ve recently bought and setup our new asterisk system with 2 BT ISDNe lines and the B410p BRI card. All is working great except for the callerid. I get the following when running:

-- Executing NoOp("mISDN/1-2", "Catch-All DID Match - Found 548282 - You probably want a DID for this.") in new stack -- Executing Goto("mISDN/1-2", "ext-did|s|1") in new stack -- Goto (ext-did,s,1) -- Executing Set("mISDN/1-2", "__FROM_DID=s") in new stack -- Executing GotoIf("mISDN/1-2", "0 ?cidok") in new stack -- Executing Set("mISDN/1-2", "CALLERID(name)=") in new stack -- Executing NoOp("mISDN/1-2", "CallerID is "" <>") in new stack -- Executing Set("mISDN/1-2", "FAX_RX=disabled") in new stack -- Executing Goto("mISDN/1-2", "ext-group|600|1") in new stack -- Goto (ext-group,600,1) -- Executing Macro("mISDN/1-2", "user-callerid|") in new stack -- Executing NoOp("mISDN/1-2", "user-callerid: ") in new stack -- Executing Set("mISDN/1-2", "AMPUSER=") in new stack -- Executing GotoIf("mISDN/1-2", "0?report") in new stack -- Executing GotoIf("mISDN/1-2", "0?start") in new stack -- Executing Set("mISDN/1-2", "REALCALLERIDNUM=") in new stack -- Executing NoOp("mISDN/1-2", "REALCALLERIDNUM is ") in new stack -- Executing Set("mISDN/1-2", "AMPUSER=") in new stack -- Executing Set("mISDN/1-2", "AMPUSERCIDNAME=") in new stack -- Executing GotoIf("mISDN/1-2", "1?report") in new stack -- Goto (macro-user-callerid,s,13) -- Executing NoOp("mISDN/1-2", "TTL: ARG1: ") in new stack -- Executing GotoIf("mISDN/1-2", "0?continue") in new stack -- Executing Set("mISDN/1-2", "__TTL=64") in new stack -- Executing GotoIf("mISDN/1-2", "1?continue") in new stack -- Goto (macro-user-callerid,s,23) -- Executing NoOp("mISDN/1-2", "Using CallerID "" <>") in new stack -- Executing GotoIf("mISDN/1-2", "1?skipdb") in new stack -- Goto (ext-group,600,4) -- Executing Set("mISDN/1-2", "__NODEST=") in new stack -- Executing Set("mISDN/1-2", "__BLKVM_OVERRIDE=BLKVM/600/mISDN/1-2") in new stack -- Executing Set("mISDN/1-2", "__BLKVM_BASE=600") in new stack -- Executing Set("mISDN/1-2", "DB(BLKVM/600/mISDN/1-2)=TRUE") in new stack -- Executing Set("mISDN/1-2", "RRNODEST=") in new stack -- Executing Set("mISDN/1-2", "__NODEST=600") in new stack -- Executing Set("mISDN/1-2", "RecordMethod=Group") in new stack -- Executing Macro("mISDN/1-2", "record-enable|200-201-202-203-204-205-206-207-208-209-210-211|Group") in new stack -- Executing GotoIf("mISDN/1-2", "0?2:4") in new stack -- Goto (macro-record-enable,s,4) -- Executing AGI("mISDN/1-2", "recordingcheck|20071204-130309|1196773389.63") in new stack -- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck -- AGI Script recordingcheck completed, returning 0 -- Executing NoOp("mISDN/1-2", "No recording needed") in new stack -- Executing Set("mISDN/1-2", "RingGroupMethod=ringall") in new stack -- Executing Macro("mISDN/1-2", "dial|20|tr|200-201-202-203-204-205-206-207-208-209-210-211") in new stack -- Executing GotoIf("mISDN/1-2", "1?dial") in new stack -- Goto (macro-dial,s,3) -- Executing AGI("mISDN/1-2", "dialparties.agi") in new stack -- Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi

Can any one help?

Many thanks