Meetme problem


#1

Hi,

I am having a problem getting conferencing to work. I have set up a simple meetme.conf and added an extension in extensions.conf, but I keep receiving a “that is not a valid conference number” message when I try to connect to the conference room. I have searched on this forum and googled the topic and have seen where there are a couple of “gotchas” for this particular error, but I can’t seem to get anything to work. Any help/suggestions would be most appreciated.

===some pertinent details===

OS = FC3 with 2.6.11-1.35_FC3 kernel
Hardware = single port fx0 card (clone); Celeron 2.4Ghz with Intel 865 board and 512MB RAM

I am using Xlite soft phones for this setup and can both place/receive calls (SIP and PSTN) fine.

===dmesg output ===
Zapata Telephony Interface Registered on major 196
ACPI: PCI Interrupt Link [LNKG] enabled at IRQ 7
PCI: setting IRQ 7 as level-triggered
ACPI: PCI interrupt 0000:01:01.0[A] -> GSI 7 (level, low) -> IRQ 7
wcfxo: DAA mode is 'FCC’
Found a Wildcard FXO: Generic Clone

===asterisk console output ===
– Executing MeetMe(“SIP/2002-a7d8”, “1234”) in new stack
== Parsing ‘/etc/asterisk/meetme.conf’: Found
– Playing ‘conf-invalid’ (language ‘en’)
== Spawn extension (from-sip, 99, 1) exited non-zero on ‘SIP/2002-a7d8’

===modprobe===

[root@sobel asterisk]# modprobe -l | grep zaptel
/lib/modules/2.6.11-1.35_FC3/misc/zaptel.ko

===/var/log/messages entry===
Jun 26 19:07:20 WARNING[4809]: Unable to open pseudo channel for timing… Sound may be choppy. ;(I assume this is the culprit)

===meetme.conf entry===
conf = > 1234 ;no whitespace at the end of the file

===extensions.conf entry===
exten => 99,1,Meetme,1234

I do an lsmod and the zaptel module is listed and lspci shows the card.

Thanks


#2

Open an Asterisk console, set the verbosity to 4 or so (“set verbose 4”), and try entering a conference. The additional verbosity should give you more information about what exactly the problem is.

If I had to make a wild guess it would be that the permissions are off on some of your Zap dev entries, but the additional console output should point to the true culprit.


#3

Thanks for the tip. Asterisk did spit more to the console. Asterisk is looking for /dev/zap/pseudo, but in /dev/zap the file is named pseuedo for some reason. Any idea why? Would a simple “mv pseuedo pseudo” do the trick you think??

===Asterisk console output===

– Executing MeetMe(“SIP/2001-350b”, “1234”) in new stack
== Parsing ‘/etc/asterisk/meetme.conf’: Found
Jun 27 08:51:16 WARNING[4534]: chan_zap.c:770 zt_open: Unable to open ‘/dev/zap/pseudo’: No such file or directory
Jun 27 08:51:16 ERROR[4534]: chan_zap.c:6731 chandup: Unable to dup channel: No such file or directory
Jun 27 08:51:16 WARNING[4534]: app_meetme.c:227 build_conf: Unable to open pseudo channel - trying device
Jun 27 08:51:16 WARNING[4534]: app_meetme.c:230 build_conf: Unable to open pseudo device
– Playing ‘conf-invalid’ (language ‘en’)

===Here is /dev/zap/ ===

[root@chelsea asterisk]# ls -l /dev/zap
total 0
crws-----T 1 root root 196, 1 Jun 26 20:23 1
crws-----T 1 root root 196, 254 Jun 26 20:22 channel
crws-----T 1 root root 196, 0 Jun 26 20:22 ctl
crws-----T 1 root root 196, 255 Jun 26 20:22 pseuedo
crws-----T 1 root root 196, 253 Jun 26 20:22 timer


#4

Yep, you can just rename the device node to fix it. Depending on which version of the Linux kernel you’re using and the options it was built with, that may not be a permanent fix, but it should fix it until the next reboot.

A permanent fix may be as simple as running grep on /etc to find a file with the typo and correcting it.


#5

What I did as a “fix” was this:

#ln -s pseuedo pseudo

in the /dev/zap/ directory

I grep’d for the pseuedo reference in /etc but could not find it. I didn’t have time for a more exhaustive search, but I’ll try to track it down later.

Right now my conference calling is working fine - thanks ColinM for your assistance.

Captain S