Media_address (change SDP IP in INVITE) not working in 16.4?

Hello,

One more question, I had:

media_address = xxx.xxx.xxx.xxx

in my sip.conf file in asterisk 11.3 before and it was able to change the SDP connection information from private to public IP.

How come that doesn’t work in 16.4 anymore? Anything other thing I need to do?

The eth0 in the 16.4 is a private IP (same as my 11.3) but with the same SIP.conf file used in 16.4, the connection IP in the SDP always show up the private IP (ip of the eth interface). While in the 11.3 it will show whatever I put in the media_address=xxx

Thank you!

If your issue is showing media address on external calls, outside from you lan verify if you are using “externaddr” or “externhost”,because the address part defined there is
also used as the external address for media session

thank you very much for you help! I finally find out that there must be a “default” setting in the sip.conf which “prevented” the public IP showing up. I’ve removed all the “;” line off and just used my old sip.conf from 11.3 and is working. The original sip.conf was generated at the time of installing 16.4. I just have to find which line was causing the problem now.

thank you!