Make install issues


I’m trying to set up Asterisk to test it in my company, and I have the following issue wich I was not able to find any answer somewhere :

I’m running it on Ubuntu 12.04 LTS and trying to install Asterisk 11

To complete the installation, I followed this tutorial : … -12-4-lts/

But when I run “./configure && make menuselect && make && make install && make config && make samples”,

First issue : make[1]: *** No rule to make target '/addons/main/
To fix it, I’ve changed makeopts.embed_rules and deleted the following lines :

And then I try to run ‘make’ and get this following errors :
make[1]: *** [asterisk] Error 1
make : *** [main] Error 2

Just before that, I’m having many issues like :
/usr/bin/ld Dwarf Error : found draft version '’,this reader only handles version 2,3 and 4 information
pbx_dundi.c : undefined reference to "ast_

Is this a compilation error ? Has it something to do with my linux version ? How can I solve this ?

Thank you in advance for your help and answers !


If you run configure only what is the output? Does it show an error or warning?

If I run the ./configure only, everything is fine, no errors or warning but during the “checking” procedure, but some chekings appears to be :

checking for * … no

And there is quite a lot of “no”

Does every checking must be “yes” ?

But at the end I see the asterisk logo and
configure: Package configured for :
configure: OS type : linux-gnu
configure: Host CPU = i686
configure: built-cpu:vendor:os: i686 : pc : linux-gnu :
configure: host-cpu:vendor:os: i686 : pc : linux-gnu :

So I guess the config as run properly

By the way, thank you for your quick reply, I appreciated !

I run Asterisk 11, on Ubuntu server 12 LTS , Flawless. Follow this guide my friend.
remember to replace the dahdi and libpri donwload links with its current version. … 18-en.html

Ok, I’m going to try and will let you know.

Thank you very much !

Everything worked fine until the installation of DAHDI…

First, I was not able to download the latest version so I’ve tried with 2.6.0

When I run make, I have those errors :

make[4]: *** [/root/src/asterisk-complete/dahdi/2.6.0+2.6.0/linux/drivers/dahdi/wcb4xxp/base.o] Error 1
make[3]: *** [/root/src/asterisk-complete/dahdi/2.6.0+2.6.0/linux/drivers/dahdi/wcb4xxp] Error 2
make[2]: *** [module/root/src/asterisk-complete/dahdi/2.6.0+2.6.0/linux/drivers/dahdi] Error 2
make[2]: Leaving directory /usr/src/linux-headers-3.5.0-23-generic' make[1]: *** [modules] Error 2 make[1]: Leaving directory/root/src/asterisk-complete/dahdi/2.6.0+2.6.0/linux’
make: *** [all] Error 2

and so I have ‘make install’ errors too…

Could you help ?

I finally manage to get the last version, no more issues now !

Thanks a lot for your help, feel free to CLOSE TOPIC !

Thanks again.