Low network latency....huge voice delay


I am testing a very basic configuration of asterisk 10 as I need a software PBX for a new project.
My rig is very basic, three computers. The first one is a 2ghz/3 Mb RAM ubuntu server only dedicated to aterisk. The second and third ones are my windows7 based powerful laptop and desktop machines. They are all connected by wire using an Inventel Livebox 2.1 router (my main home ADSL router) working as a switch (wifi desconnected)

These are the steps I’ve followed so far:

  1. Fresh ubuntu server instalation (no issues)
  2. Fresh asterisk 10 installation (no isues)
  3. Basic iax.conf and extensions.conf files (two users, just anwer and hangup in extensions.conf)
  4. Zoiper phones instalation in windows computers.
  5. Router configuration (forward port 4560 to asterisk IP, for further testing outside my lan).

Ok, so everything seems fine, both zoiper phones register,I can make calls, flawless sound quality, but…

HUGE VOICE DELAY, more than 600 ms (measured by echo test). This makes conversation unpracticable.

I’ve checked my basic network, ping tests show 5 ms, wireshark tests show an average of 20 ms, no firewalls on the router, Windows firewalls disconnected…

As there’s not remarkable traffic between three machines…I believe it’s not a network issue. I’d then like to look elsewhere…

Is this normal? Where should I look at?

I am deseperate. You have probably already noticed that I am not a tech. Any help will be really appreciated.

AFAIK swith type on the router is not Gigabite, just fast ethernet, just in case that matters…

Thanks in advance.

384kB is too little for Asterisk. Did you mean G, rather than M and B rather than b?

If you can run wireshark, you should be able to establish where the latency is introduced.

Hi David,

Thanks a lot for your prompt response.

Sorry, I meant 3 Gb RAM. The server seems to run quite confortable.

As stated, I am not a tech, so everything I can see in Wireshark is a Delta average of 25 ms (Iax2 stream analysis)
Would you be as kind as to indicate where should I look to identify where the latency is created?

I’ve also performed a similar call test connecting from outside (not LAN, but internet) , and I get exactly the same lag.

Thanks again.

You need to match up the timestamp fields in the incoming and outging RTP packets and see whether there is significantly more than 20m difference. (If they are from different sequences, you will need to try and match contents, which is more difficult.

A 600ms delay is most likely to occur at the destination, due to inappropriate latency buffers, but that could be due to the fact that Asterisk doesn’t handle the synchronisation source correctly (Cisco phones, at last through CUCM, have this problem).

I can’t see any relevant difference between packets. Those outlining packets do not go beyond the 100 ms border.

As stated, my extensions.conf and iax2.conf files are pretty basic. I tried to solve this including jitterbuffer=yes, but no effect. Did some google, forum search, nothing, everything refers to traffic which doesn’t seem to be my problem.

What do you mean the syncronization source? it’s just two zoipers, one server. No hardphones, asterisk is smoothly running on a dedicated server.

I will post what I get from wireshark just in case I am not looking in the right place.

Any suggestion will be very very appreciated.


  • Turned echo cancellation off in zoiper…did not solve the problem, lag is still there.
  • Tried zoiper mobile for android…it worked but did not solve the problem, lag is still there.
  • Tried different softphones…did not solve the problem.
  • Installed ubuntu on a virtual machine in one of the client machines…it worked but did not solve the problem, lag is still there.

coming next…

Change every piece of hardware involved (clients, server, switch…)

Of course, any suggestion will be more than welcome.

i’ll keep you updated…

I got myself a powerful switch.

I then reconfigured my LAN using JUST the switch and manually assigning IP addresses to each machine.


The only thing that’s avoiding me from quitting (and find another solution) is that the VU metert on the mic input of the zoipers graphically shows the lag. I mean, the meter raises half a second after I speak at the mic, which may mean that the lag is produced BEFORE reaching the softphone and therefore, Asterisk is just transmitting it.

Is it possible?

I am using an standard mic connected to Windows sound input… do I need any special driver (like ASIO drivers for music) to solve the problem?

If that’s the reason…why am I getting the same lag using two mobile zoipers under android (not using a pc at all)?

Please help, any suggestion is appreciated.