IVR : No sound. I can't hea anything


#1

Hello,

I’ve reccorded a voice message for the IVR. (.wav, 16 bits, 8kHz)
The file is /var/lib/asterisk/sound/11ivrrecording.wav.

When asterisk (1.2.5) starts this file i can’t hear it on my phone.

It’s a SIP phone (extension 11) which is on a switch with the Asterisk server.

Here is the log :

Apr 6 17:00:16 VERBOSE[845] logger.c: – Executing SetCallerID(“SIP/11-97b9”, ““Patrice” <11>”) in new stack
Apr 6 17:00:16 VERBOSE[845] logger.c: – Executing NoOp(“SIP/11-97b9”, “Using CallerID “Patrice” <11>”) in new stack
Apr 6 17:00:16 VERBOSE[845] logger.c: – Executing Playback(“SIP/11-97b9”, “11ivrrecording”) in new stack
Apr 6 17:00:16 DEBUG[845] channel.c: Scheduling timer at 160 sample intervals
Apr 6 17:00:16 VERBOSE[845] logger.c: – Playing ‘11ivrrecording’ (language ‘en’)
Apr 6 17:00:17 DEBUG[26916] chan_sip.c: Stopping retransmission on ‘xqOZotDBq6ICZb9l@192.168.42.24’ of Response 2: Match Found
Apr 6 17:00:49 DEBUG[26916] chan_sip.c: Stopping retransmission on ‘4c14706a2d71d234273cdc26207692b1@192.168.42.10’ of Request 102: Match Found
Apr 6 17:00:50 DEBUG[845] channel.c: Scheduling timer at 0 sample intervals
Apr 6 17:00:50 VERBOSE[845] logger.c: == Spawn extension (from-internal, *99, 2) exited non-zero on ‘SIP/11-97b9’

Anyone has an idea ?

Thanks a lot.

Antoine


#2

This could be a possible NATing problem. If you are not behind any NAT device then ignore this else refer SIP & NAT issues in voip-info site.


#3

Thanks for your answer.

I’m not behind a NAT.

Asterisk and the softphones are on the same switch.


#4

How about recording the file in gsm and see what happens.


#5

Thanks for your answer.

I’ve test my microphone and it works.

I’ve created a new sip extension (‘40’) in a ‘test’ context.

[test]
exten => 40,1,Wait(2)
exten => 40,2,Record(/var/lib/asterisk/sounds/40ivr:gsm)
exten => 40,3,Wait(2)
exten => 40,1,Playback(/var/lib/asterisk/sounds/40ivr)
exten => 40,1,Hangup

When i dial 40, the record app begins. I speak the file is created in the directory. But it doesn’t go on. The file is 0 ko and there is no :
exten => 40,3,Wait(2)
exten => 40,1,Playback(/var/lib/asterisk/sounds/40ivr)
exten => 40,1,Hangup

I’don’t know what to do…

Thanks for your help.


#6

If the Playback worked you will see this:

– AGI Script Executing Application: (Playback) Options: (/var/spool/asterisk/tmp/naturalvoice_0b5a8)
– Playing ‘/var/spool/asterisk/tmp/naturalvoice_0b5a8’ (language ‘en’)

both lines, and on your I don’t see the second line (-- Playing), so that means the file is missing, Asterisk doesn’t have access to read the file, or the file isn’t compatible…


#7

No, the record never stops so it doesn’t go on to the playback application.

I’ve tried whith record(ivr:gsm|5|30) and it’s the same. The record never stops :frowning:


#8

hmm…i cant see the line ASNWERING your call before you playback a soundfile… :wink:

Remember:
A call not answered cant listen to a playback file.

According to your log:
Apr 6 17:00:16 VERBOSE[845] logger.c: – Executing SetCallerID(“SIP/11-97b9”, ““Patrice” <11>”) in new stack
Apr 6 17:00:16 VERBOSE[845] logger.c: – Executing NoOp(“SIP/11-97b9”, “Using CallerID “Patrice” <11>”) in new stack
Apr 6 17:00:16 VERBOSE[845] logger.c: – Executing Playback(“SIP/11-97b9”, “11ivrrecording”) in new stack

there should be an
exten=> whatevernumber,3,answer
exten=> whatevernumber,4,playback(nameoffile.wav)

Either you convert to GSM or you supply the fileextension !
WAV isnt THAT good format on linux/asterisk, i would convert it to GSM.