Issues with reconfiguring Cisco 6921 from SCCP to SIP for *

Good afternoon, everyone.

I have an aim to make possible work of Cisco IP Phone 6921 with and Asterisk server, using SIP. Asterisk is being based on CentOS 6.4, tftp server have already been set up, and next files put into /tftpboot folder:

BOOT69xx.0-0-0-14.zz.sgn DSP69xx.0-0-0-8.zz.sgn SEP649EF3B161CC.cnf.xml SIP69xx.9-2-1-0.loads SIP69xx.9-2-1-0.zz.sgn XMLDefault.cnf.xml

At the same time, I see in tftp logs next information:

Jun 13 16:39:32 asterisk-test-01 in.tftpd[2450]: RRQ from filename XMLDefault.cnf.xml Jun 13 16:40:06 asterisk-test-01 in.tftpd[2453]: RRQ from filename CTLSEP649EF3B161CC.tlv Jun 13 16:40:06 asterisk-test-01 in.tftpd[2454]: RRQ from filename SEP649EF3B161CC.cnf.xml
As i know, file *.tlv is not necessary for asterisk, so there I haven’t put it into tftpboot folder.

XMLDefault.cnf.xml has the next contents:

<Default> <callManagerGroup> <members> <member priority="0"> <callManager> <ports> <ethernetPhonePort>2000</ethernetPhonePort> </ports> <processNodeName></processNodeName> </callManager> </member> </members> </callManagerGroup> <loadInformation8 model="IP Phone 6921">SIP69xx.9-2-1-0</loadInformation8> </Default>

Where I have failed? Thank you!

What is the correct SEP(MAC).cnf.xml correct for works in asterisk?

did you solve the problem? if you solved then could you tell me explain?

It probably cannot find the file. Is it actually reaching the server at all?
Do a tcpdump of the tftp traffic and compare those files exactly with what you have.

I would go with a later version. Based upon that check your SEPMAC.cnf.xml file SIP69xx.9-4-1-3 worked well for me. Along with that file, I needed:

For me, unlike other cisco phones, the macaddress within the “SEP…cnf.xml” file had to have capitalized alpha characters, so double check that, too.

If you don’t see any traffic from that tcp dump, you’ll have to check all of your files. I think XMLDefault.cnf.xml plays a key role here, but yours looks correct; problem is probably the load. Put it in your SEP.cnf.xml file as mentioned above. I’ll put it here again for reference:

You have to do a wipe of the phone, too. Reboot, hold # and wait for the line keys to light up green. Then dial 123456798*0#. Once you dial 1 in that sequence the line keys will go from green to red. Once the whole sequence is successful and the format begun, the MWI light will turn red.